Support » Fixing WordPress » URL links revert to old images

  • Resolved feedbaylenny

    (@feedbaylenny)


    Hi! I’m using URLs of images from the National Weather Service. These links update daily at least (the watches and warnings even more often).

    When editing, I see what I’m supposed to see with today’s date. On the live site, the images revert to old ones, from last week or even last month.

    Last week, I had a chat, I believe with WordPress, and the guy used the Classic Editor to test on the bottom of the page, so I changed everything to that. Unfortunately, that didn’t help.

    Making big changes would be no big deal, since the page should run and update on its own.

    Do you know why the images revert to old ones on the live site, and how to stop that from happening?

    Thank you!

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Last week, I had a chat, I believe with WordPress,

    Your website is hosted with GoDaddy. So your chat was probably with GoDaddy support staff, not “WordPress” as you believe.

    Do you know why the images revert to old ones on the live site, and how to stop that from happening?

    My best guess is JetPack’s image CDN which is showing previously cached images. From the “LIMITATIONS” section of Jetpack’s Site Accelerator page:

    No cache invalidations – currently the images are cached “forever” and static assets will be tied to the public version of WordPress, Jetpack, or WooCommerce that you’re using. For images, if you want to “refresh” an image you will need to change its file name. Adding random query arguments, commonly known as cachebusters, will not work.

    See: https://jetpack.com/support/site-accelerator/

    So your options are:

    1) Keep changing the image URLs if you can. OR

    2) Disable the “Speedup image load times” option in Jetpack’s Site Accelerator.

    Good luck!

    feedbaylenny

    (@feedbaylenny)

    OMG! You are amazing!

    I have a blog on WordPress.com, which I’ll be moving over when the domain is about to expire in the spring, so I have two Jetpacks. The first kept giving me error messages, even when I shut off “Enable site accelerator” but I finally found the second and it worked.

    For some reason, it always worked on the right-side widgets, so I used that as my guide.

    THANK YOU!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘URL links revert to old images’ is closed to new replies.