Support » Plugin: Edit Author Slug » URL is not available to Google

  • Hi Brandon,
    I changed the Author Base to “member”, all works well, yet SEO wise, Google is unable to index the new author base, which explains the fact when I tried accessing the old author slug, I get Content not found.

    Is your plugin supposed to take care of the redirection?
    If not, how can we go by to force a redirect from the old “author” to example “member” slug?

    I tried many ways in htaccess but none of them worked.

    RewriteRule ^author/?$ $1/member$2 [R=301,L]
    RewriteRule ^member/(.*) author/$1
    RewriteCond %{THE_REQUEST} ^GET\ /author/
    RewriteRule ^author/(.*) /member/$1 [L,R=301]

    Options +FollowSymLinks
    RewriteEngine On
    RewriteRule ^(.*)/author/(.*)$ $1/member/$2 [R,L]

  • You must be logged in to reply to this topic.