Support » Plugin: Content Scheduler » URL in email not working

  • Resolved stemlund

    (@stemlund)


    I’m using this plugin with a custom post type and in my notification emails, the URL that should link to the page is broken. The URL is produces is: mydomain.com/?post_type=knowledgebase&p=306 which ends up taking me to a page that displays all posts in that post type, not the individual post in question.

    How can this be fixed?

    https://wordpress.org/plugins/content-scheduler/

Viewing 2 replies - 1 through 2 (of 2 total)
  • It looks like the URL ends up displaying as /?post_type=knowledgebase& # 0 3 8 ;p=306 so it is using & # 0 3 8 ; (with no spaces, because this forum switches it to just &) in place of & – is there a setting in functions.php or .htaccess to make URLs translate that entity to just &?

    Looks like there will be no help here. Luckily I solved the issue. It looks like using the GUID is no longer recommended

    in /includes/send-notification.php, you would need to change line 66 to

    $post_view_url = get_permalink($post_data['ID']);

    instead of the original code that tries to get the ‘guid’.

    This solved my issue.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘URL in email not working’ is closed to new replies.