Support » Fixing WordPress » URL having a lot of letters and numbers after

  • I need some help with my site, because the URL is not clean. Theres is a lot of letters and numbers after every page URL. And I have tried to change it under “permanent links”. But whatever I do, its not helping.

    Can someone help me figuring the problem out? πŸ™‚

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi @wuthcopenhagen21

    Can you please check the URL in admin with the edit page screen?
    Also, Can you please try to update “permanent” with “Post Name” from admin?

    Thanks,

    Thread Starter wuthcopenhagen21

    (@wuthcopenhagen21)

    As you can see the link is normal, but when I’m trying to see our website in Crome it makes this UR – Lhttps://www.wuthcopenhagen.com/?v=dd65ef9a5579

    What do you mean with permanent? πŸ™‚

    Thread Starter wuthcopenhagen21

    (@wuthcopenhagen21)

    URL

    Thread Starter wuthcopenhagen21

    (@wuthcopenhagen21)

    Perma link

    And as you can see here, we already have the link under Post Name, so it should be right.

    Ok, Everything is fine. Have you done anything related to “v=dd65ef9a5579” on the website?

    Which plugin you have installed?

    Hi, @wuthcopenhagen21

    This string ?v=abcdefgh appears because you are using WooCommerce. It is not a bug, but an actual feature of the plugin. It helps WooCommerce to localize your store but at the same time being able to be compatible with WordPress caching plugins.

    However, if you don’t need this feature, or you don’t like the added parameter to your URL, here’s how you can disable this.

    Navigate to Dashboard Β» WooCommerce Β» Settings and under the General tab scroll down to Default customer location option. Then, you need to change it to ‘No location by default’ or ‘Shop base address’. Don’t forget to hit Save options. If you have a cache plugin, also clear cahce.

    Please note, if you need to GeoLocate and use a Cache plugin, this is not an option.

    v-woo

    Hope this helps,
    Kind regards!

    Thread Starter wuthcopenhagen21

    (@wuthcopenhagen21)

    Oh, thank you so much Vlad T.

    Really great with the information, and it makes sense.
    I have changed it, and now it works. So thank you so much πŸ™‚

    Have a great day!

    Happy to help! Glad it works! πŸ™‚

    If your question has been answered, we would love if you would mark this topic as resolved in the sidebar. This helps our volunteers find the topics that still need attention and more people will get helped, possibly like you did.
    Thank you!

    @radixweb your initial suggestion was a perfectly valid debugging starting point. Thank you for your contribution on these forums! Much appreciated. Best of luck!

    @vladytimy Thank you πŸ™‚

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘URL having a lot of letters and numbers after’ is closed to new replies.