Support » Plugins and Hacks » [Resolved] URL for languages return a Not Found error.

[Resolved] URL for languages return a Not Found error.

  • Hi,

    URL (or pages?) for languages other than the default doesn’t work for my theme. For example, mydomain.com/es or mydomain.com/de show a Not Found. That’s because I’m missing something necessary in my theme? I don’t have a page.php… that’s the reason? I checked the .htaccess rewrite rules and everything is fine.

    Thank you for your support!


Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Takayuki Miyoshi


    Do you have *.mo files for those languages in wp-content/languages directory?

    Plugin Author Takayuki Miyoshi


    Or, in another way, do you see those languages in the admin-bar menu?

    Yes. I placed the *.mo files in wp-content/languages and Language Switcher is in the admin-bar menu. A metabox is shown in the sidebar for edit-post page and I can add/edit/manage pages in several languages as expected. Column for Locales is there, too.

    Than you again for your help!

    Plugin Author Takayuki Miyoshi


    OK. Maybe you need flushing WordPress’s rewrite rules. Go to menu Settings > Permalinks, change something and save changes. It will frush your rewrite rules.

    Hi im having a similar issue

    1. Installed plugin
    2. installed french language files and put them into wp-content/languages
    3. created a page in english ( default language)
    4. used admin bar to switch languages, but it didnt say french, it says “rosetta-fr_FR”
    5. trying to view the page in french gives a 404 error
    6. the dashboard never changed to french while creating the page
    7. the documents in /languages are rosetta-fr_FR.mo, rosetta-fr_FR.po and shots-fr_fr.png

    I´m not sure how to fix the issue, ive tried changing the rewrite rules to fix the 404 error with no luck

    hope you can help, thanks in advance

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] URL for languages return a Not Found error.’ is closed to new replies.