WordPress.org

Support

Support » How-To and Troubleshooting » url-encode in wordpress

url-encode in wordpress

  • Hi.
    I’m from Poland and now when I add a post i have url like: domain.pl/topic_name.html but when I add some of polish words like “dzierżązna” url is domain.pl/dzierzazna.html (wordpress change polish mark like ą ę to a e) but I wanna use url_encode and i want urls like domain.pl/dzier%C5%BC%C4%85zna.html Where i can find tthis in wordpress and how i can change this?
    Greetings.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Does anybody know?

    Ok. I found this:

    <?php
    function sanitize_title_with_urlencode($title) {
    $title = urlencode($title);
    $title = strtolower($title);
    $title = str_replace(‘+’, ‘-‘, $title);
    return $title;
    }

    remove_action(‘sanitize_title’, ‘sanitize_title_with_dashes’);
    add_action(‘sanitize_title’, ‘sanitize_title_with_urlencode’);

    ?>

    Hi there, I have similar problem with my WP 2.1. I/ have installed in on http://zespółaperta.pl domain, no images are shown, also links are generated in wrong way: http://zespaperta.pl/…, so the “ół” phrase is omitted. Also I realised there’s something wrong with options, the settings WordPress address and Blog address are somehow filtered so, even updated they become with the same “ół” error .
    I suppose Afrael’s solution could help but I don’t know how to use the code he shared.

    Any help, please?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘url-encode in wordpress’ is closed to new replies.