Support » Plugin: 404 Solution » URL empty in logs since upgrading?

  • Resolved ozzymuppet

    (@ozzymuppet)


    Hello,

    I just checked the logs today and found that for the last 1.5 days the URLS are all blank. Every single one from a log at 9:24am 24th May CDT, until right now.

    Screenshots – http://imgur.com/a/PDFnv

    I suspect this was since upgrading to new version? I will try uninstall and reinstall.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Aaron

    (@aaron13100)

    Hey ozzymuppet. I would guess that you’re right that it’s due to the new version.

    What does the debug log look like when a redirect is recorded? 404 Solution -> Options -> General Settings -> Debug Logging (activate it) then “View”

    It should look something like this…

    2017-05-26 12:18:51 (DEBUG): Processing 404 for URL: /2016/06/the-differences-between-rich-and-wealthy/ | Redirect: {"id":"423","url":"\/2016\/06\/the-differences-between-rich-and-wealthy\/","status":"2","type":"1","final_dest":"74","code":"301","disabled":"0","timestamp":"1490172149"} | is_single(): | is_page(): | is_feed(): | is_trackback(): | is_preview(): | options: auto_redirects: 1, auto_score: 90, auto_cats: 1, auto_tags: 1, dest404page: 0|0, HTTP_USER_AGENT: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0), REMOTE_ADDR: 138.75.82.90, REQUEST_URI: /2016/06/the-differences-between-rich-and-wealthy/
    2017-05-26 12:18:51 (DEBUG): Logging redirect. redirect_id: 423 | Referer: | Current user: | From: /2016/06/the-differences-between-rich-and-wealthy/ to: https://www.wealth-psychology.com/the-differences-between-rich-and-wealthy/, Reason: existing

    Are there any error messages in the debug log?

    thanks

    I just went on a deleting spree to clean out some auto redirects and now the logging has come back, after more than 24 hours… weird.

    I turned on debug and put in an obviously incorrect address so you can see the logs (below). I can’t see any obvious errors.

    What did concern me though is that it’s logged a valid URL (for an image) and says it redirected to my default homepage. Strange no? http://imgur.com/a/uK7XP When I do the same, it does’nt appear in the log again…. also strange heh.

    LOG

    2017-05-24 10:06:35 (INFO): Updating database version (begin).
    2017-05-24 10:06:35 (INFO): 734 log rows were migrated to the new table structre.
    2017-05-24 10:06:35 (INFO): Updating database version (end).
    2017-05-24 14:01:30 (INFO): deleteOldRedirectsCron. Old captured URLs removed: 0, Old automatic redirects removed: 0, Old manual redirects removed: 0, Old log lines removed: 0, Duplicate rows deleted: 7
    2017-05-25 14:01:05 (INFO): deleteOldRedirectsCron. Old captured URLs removed: 0, Old automatic redirects removed: 0, Old manual redirects removed: 0, Old log lines removed: 0, Duplicate rows deleted: 22
    2017-05-26 13:45:23 (DEBUG): Displaying sub page: abj404_options
    2017-05-26 13:45:28 (DEBUG): Processing request for action: (none)
    2017-05-26 13:45:28 (DEBUG): Displaying sub page: abj404_debugfile
    2017-05-26 13:46:18 (DEBUG): Processing 404 for URL: /wp-content/charts/1004407.png | Redirect: {"id":0} | is_single(): | is_page(): | is_feed(): | is_trackback(): | is_preview(): | options: auto_redirects: 1, auto_score: 80, auto_cats: 0, auto_tags: 0, dest404page: 4488|1, HTTP_USER_AGENT: Googlebot-Image/1.0, REMOTE_ADDR: [REMOVED IP 2], REQUEST_URI: /wp-content/charts/1004407.png
    2017-05-26 13:46:18 (DEBUG): No posts or pages matching slug: 1004407.png
    2017-05-26 13:46:28 (DEBUG): Logging redirect. redirect_id: 9325 | Referer: | Current user: | From: /wp-content/charts/1004407.png to: https://www.REMOVED.com/REMOVED, Reason: user specified 404 page
    2017-05-26 13:46:45 (DEBUG): Processing request for action: (none)
    2017-05-26 13:46:45 (DEBUG): Displaying sub page: abj404_debugfile
    2017-05-26 13:47:17 (DEBUG): Processing request for action: (none)
    2017-05-26 13:47:17 (DEBUG): Displaying sub page: abj404_redirects
    2017-05-26 13:47:28 (DEBUG): Processing request for action: (none)
    2017-05-26 13:47:28 (DEBUG): Displaying sub page: abj404_logs
    2017-05-26 13:47:28 (DEBUG): 473 redirects found for logs page select option.
    2017-05-26 13:47:29 (DEBUG): 500 log records displayed on the page.
    2017-05-26 13:48:40 (DEBUG): Processing 404 for URL: /dsa/dkauw | Redirect: {"id":0} | is_single(): | is_page(): | is_feed(): | is_trackback(): | is_preview(): | options: auto_redirects: 1, auto_score: 80, auto_cats: 0, auto_tags: 0, dest404page: 4488|1, HTTP_USER_AGENT: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0, REMOTE_ADDR: [REMOVED IP], REQUEST_URI: /dsa/dkauw
    2017-05-26 13:48:40 (DEBUG): No posts or pages matching slug: dkauw
    2017-05-26 13:48:52 (DEBUG): Logging redirect. redirect_id: 9326 | Referer: | Current user: REMOVED_ADMIN_ACCOUNT | From: /dsa/dkauw to: https://www.REMOVED.com/REMOVED, Reason: user specified 404 page
    2017-05-26 13:48:59 (DEBUG): Processing 404 for URL: /wp-content/charts/1004407.png | Redirect: {"id":0} | is_single(): | is_page(): | is_feed(): | is_trackback(): | is_preview(): | options: auto_redirects: 1, auto_score: 80, auto_cats: 0, auto_tags: 0, dest404page: 4488|1, HTTP_USER_AGENT: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0, REMOTE_ADDR: [REMOVED IP], REQUEST_URI: /wp-content/charts/1004407.png
    2017-05-26 13:48:59 (DEBUG): No posts or pages matching slug: 1004407.png
    2017-05-26 13:48:59 (DEBUG): Processing 404 for URL: /wp-content/uploads/blank.gif | Redirect: {"id":0} | is_single(): | is_page(): | is_feed(): | is_trackback(): | is_preview(): | options: auto_redirects: 1, auto_score: 80, auto_cats: 0, auto_tags: 0, dest404page: 4488|1, HTTP_USER_AGENT: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0, REMOTE_ADDR: [REMOVED IP], REQUEST_URI: /wp-content/uploads/blank.gif
    2017-05-26 13:48:59 (DEBUG): No posts or pages matching slug: blank.gif
    2017-05-26 13:49:07 (DEBUG): Logging redirect. redirect_id: 9327 | Referer: https://www.REMOVED.com/REMOVED | Current user: REMOVED_ADMIN_ACCOUNT | From: /wp-content/uploads/blank.gif to: https://www.REMOVED.com/REMOVED, Reason: user specified 404 page
    2017-05-26 13:49:07 (DEBUG): Logging redirect. redirect_id: 9328 | Referer: https://www.REMOVED.com/REMOVED | Current user: REMOVED_ADMIN_ACCOUNT | From: /wp-content/charts/1004407.png to: https://www.REMOVED.com/REMOVED, Reason: user specified 404 page
    2017-05-26 13:49:07 (DEBUG): Processing request for action: (none)
    2017-05-26 13:49:07 (DEBUG): Displaying sub page: abj404_debugfile
    Plugin Author Aaron

    (@aaron13100)

    I found the issue. I have to test a bit more before fixing it. Thanks for the heads up! I’ll post a note here when it’s fixed…

    No worries, thanks for the great plugin.

    Plugin Author Aaron

    (@aaron13100)

    Alright it should be fixed with version 1.7.1 that I just made available. I trust you’ll let me know if you notice any issues. 🙂
    thanks

    No worries, thanks! 🙂

    It looks like the purge logs feature is missing. Only “redirects” is visible in the dropdown.

    Screenshot: http://imgur.com/a/Mwgvd

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘URL empty in logs since upgrading?’ is closed to new replies.