WordPress.org

Forums

[resolved] URL change crash (18 posts)

  1. salmaak7
    Member
    Posted 1 year ago #

    I changed my website URL (http://localhost:8888/wordpress/) from settings so it crashed. Then I managed to fix it by going to http://localhost:8888/wordpress/wp-admin and now I can access every page in my website EXCEPT the home page!
    Whenever I try to press "Visit site" or type in http://localhost:8888/wordpress/ it directs me to http://localhost/wordpress/ and gives me the "Unable to connect. Firefox can't establish a connection to the server at localhost" message.

    Please help.
    Thanks

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Change the urls back. See Changing_The_Site_URL for details of how to do this correctly without logging in.

  3. salmaak7
    Member
    Posted 1 year ago #

    I did change it and every other page is working properly except the home page. I can even access the dashboard and see that it's changed!

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Please re-read my post above.

  5. salmaak7
    Member
    Posted 1 year ago #

    I read it, AND followed the instructions (Edit wp-config.php and Functions.php) which changed the WordPress Address (URL) to http://localhost:8888/wordpress/
    and the site address is the same i.e.
    Site Address (URL) http://localhost:8888/wordpress/

    The website is running now EXCEPT the home page. It keeps redirecting me to localhost/wordpress from http://localhost:8888/wordpress/
    Any ideas?
    I am really stuck!

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    Edit wp-config.php and Functions.php

    No - you only use one of the methods outlined on that page - not two or more.

  7. salmaak7
    Member
    Posted 1 year ago #

    Okay, I've undone everything and only edited the wp-config.php this time. The homepage is still not working. I just don't get why is it redirecting me to localhost/wordpress instead of http://localhost:8888/wordpress/

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    So what have you added to your wp-config.php file?

  9. salmaak7
    Member
    Posted 1 year ago #

    I've added this: define('WP_HOME','http://localhost:8888/wordpress/');
    define('WP_SITEURL','http://localhost:8888/wordpress/');

  10. esmi
    Forum Moderator
    Posted 1 year ago #

    So you are trying to move WP from the root domain to a sub-folder? If "yes", then you need to review Moving_WordPress.

  11. salmaak7
    Member
    Posted 1 year ago #

    No, I am not trying to move anything. I just want to access my home page and it's not working...

  12. esmi
    Forum Moderator
    Posted 1 year ago #

    Where was WP originally installed on your server?

  13. salmaak7
    Member
    Posted 1 year ago #

    It was originally installed on Applications/Wordpress and I'm using MAMP
    Then I changed its location to Documents/server/wordpress. It was working fine until I changed the URL.

  14. esmi
    Forum Moderator
    Posted 1 year ago #

    So you moved the site after it was installed! You need to review Moving_WordPress.

  15. salmaak7
    Member
    Posted 1 year ago #

    Okay, now I read it and placed this: //FIXME: do comment/remove these hack lines. (once the database is updated)
    update_option('siteurl', 'http://localhost:8888/wordpress/' );
    update_option('home', 'http://localhost:8888/wordpress/' );
    in the wp-login.php file.

    And the homepage still doesn't work.

  16. esmi
    Forum Moderator
    Posted 1 year ago #

    You have to follow all of the steps in Moving_WordPress.

  17. salmaak7
    Member
    Posted 1 year ago #

    But everything worked perfectly fine AFTER I changed the location.
    I only changed the location in the beginning before I ever start working on anything on my website. It was working perfectly fine and I developed everything on the new location. I also made it the Apache document root from the MAMP preferences. I do NOT want to change the wordpress location as it is not the problem at all.
    The only problem is in the URL change. How can I fix this?!
    It has NOTHING to do with moving wordpress.

  18. closmarfer
    Member
    Posted 10 months ago #

    I have the same problem. I think the problem is the browser. Delete browser's cache and it works. I have solved this problem in Firefox 33.
    Regards!

Topic Closed

This topic has been closed to new replies.

About this Topic