Support » Plugin: Yoast SEO » Url breadcrumbs not updated to https protocol

  • Resolved danielefratin

    (@danielefratin)


    Hello guys,
    I have one issue with breadcrumbs link on portfolio item pages.

    After changed the site protocol form http to https I have a problem with the breadcrumbs url for all the pages related to portfolio page.
    All the other links are ok with the https, but portfolio link points to http version.

    Is there a way to correct this issue?

    Thank you!
    Daniele

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Maybellyne

    (@maybellyne)

    Hello,

    Are these examples of URLs of the portfolio pages?

    https://www.venetocomunicazione.it/progetti/martex/
    https://www.venetocomunicazione.it/progetti/cb-design/

    If yes, then, they are loading as HTTPS. And if no, can you also share those with HTTP?

    Thanks

    Dear Maybellyne,
    thank you for your replay.

    Just yesterday I found a workaround to solve the issue.
    I added the following php script to the function file:

    // define the wpseo_breadcrumb_single_link callback -> (update wrong http url part to https)

    function filter_wpseo_breadcrumb_single_link( $link_output, $link ) {
    // make filter magic happen here…
    if (strpos($link_output, ‘http://’) !== false) {
    $link_output = str_replace ( ‘http://’ , ‘https://’ , $link_output);
    }

    return $link_output;
    };

    // add the filter
    add_filter( ‘wpseo_breadcrumb_single_link’, ‘filter_wpseo_breadcrumb_single_link’, 10, 2 );

    // End of script

    And it works well!
    Hope this can find someone else!

    Have a nice day!
    Daniele

    YES! I recently did an audit and noticed that my site (which is forced SSL) had breadcrumb links that were not https:! Wish there was a way to make sure that the links were https: I will use the function left by Daniel until this is fixed.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.