Support » Plugin: Complianz - GDPR/CCPA Cookie Consent » URL blocking from specific plugin path

  • Resolved pixelhafendesign

    (@pixelhafendesign)


    I have currently installed the Woowbot Woocommerce Chatbot Pro plugin. Unfortunately, the developer has not really responded to my questions because of the GDPR.

    Now I have found the possibility in Complianz to block URL’s and or unique strings from the inline scripts of third parties until consent has been granted.

    I have entered the following there:

    meinfotowunder.de/wp-content/plugins/woowbot-woocommerce-chatbot-pro
    /wp-content/plugins/woowbot-woocommerce-chatbot-pro
    https://www.meinfotowunder.de/wp-content/plugins/woowbot-woocommerce-chatbot-pro
    plugins/woowbot-woocommerce-chatbot-pro
    /plugins/woowbot-woocommerce-chatbot-pro

    Unfortunately this does not work, the scripts are loaded anyway. I have also cleared the cache several times.

    Is there a possible solution for this? Thanks in advance

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Contributor Aert

    (@aahulsebos)

    Hi @pixelhafendesign,

    I see you’re minifying and combining Javascript files, could you disable this so we have a look at which Javascript file needs to be blocked?

    Some custom CSS;

    #cc-window {
        z-index: 9999999;
    }

    This will make sure the banner stays on top of the chatbot on a revoke.

    Let me know,
    regards Aert

    Thread Starter pixelhafendesign

    (@pixelhafendesign)

    Hi Aert,

    is done. I have temporarily disabled the Fast Velocity Minify plugin and added the CSS code.

    Best regards
    Marcel

    Plugin Contributor Aert

    (@aahulsebos)

    Hi @pixelhafendesign,

    I think ‘woowbot-woocommerce-chatbot-pro,’ should work. But it might be an issue with minification. Could you try excluding the plugin from minification?

    regards Aert

    Thread Starter pixelhafendesign

    (@pixelhafendesign)

    Hi @aahulsebos,

    I have now tested this once with the FVM plugin disabled and then come to the conclusion that Woowbot is loaded anyway. The entries I have used for this in Complianz are these:

    meinfotowunder.de/wp-content/plugins/woowbot-woocommerce-chatbot-pro
    /wp-content/plugins/woowbot-woocommerce-chatbot-pro
    https://www.meinfotowunder.de/wp-content/plugins/woowbot-woocommerce-chatbot-pro
    plugins/woowbot-woocommerce-chatbot-pro
    /plugins/woowbot-woocommerce-chatbot-pro
    woowbot-woocommerce-chatbot-pro

    I have the entries once in the window for “(Part of) URL’s or unique strings from inline scripts of third party scripts and plugins that should be blocked before consent.” and “URL’s of iFrames that should be blocked before consent.”

    Then I had FVM enabled and excluded from minification and combination. Thereupon woowbot doesn’t appear on the page at all strangely enough but the cookies are set anyway. So this seems to be more of a problem with the bot.

    Am I possibly using the wrong paths with Complianz?

    Translated with http://www.DeepL.com/Translator (free version)

    Thread Starter pixelhafendesign

    (@pixelhafendesign)

    I have now simply taken the source code from the home page and searched there for woowbot. The corresponding .js files I have now added to the integration as follows:

    https://www.meinfotowunder.de/wp-content/plugins/woowbot-woocommerce-chatbot-pro/conversion-tracker//front/js/script.js
    https://www.meinfotowunder.de/wp-content/plugins/woowbot-woocommerce-chatbot-pro/js/qcld-woo-chatbot-plugin.js
    https://www.meinfotowunder.de/wp-content/plugins/woowbot-woocommerce-chatbot-pro/js/jquery.magnific-popup.min.js
    https://www.meinfotowunder.de/wp-content/plugins/woowbot-woocommerce-chatbot-pro/js/jquery.cookie.js
    https://www.meinfotowunder.de/wp-content/plugins/woowbot-woocommerce-chatbot-pro/js/jquery.slimscroll.min.js
    https://www.meinfotowunder.de/wp-content/plugins/woowbot-woocommerce-chatbot-pro/js/qcld-woo-chatbot-front.js
    /plugins/woowbot-woocommerce-chatbot-pro/conversion-tracker//front/js/script.js
    /plugins/woowbot-woocommerce-chatbot-pro/js/qcld-woo-chatbot-plugin.js
    /plugins/woowbot-woocommerce-chatbot-pro/js/jquery.magnific-popup.min.js
    /plugins/woowbot-woocommerce-chatbot-pro/js/jquery.cookie.js
    /plugins/woowbot-woocommerce-chatbot-pro/js/jquery.slimscroll.min.js
    /plugins/woowbot-woocommerce-chatbot-pro/js/qcld-woo-chatbot-front.js

    Yet these are still loading without cookie consent. I don’t understand this somehow. WP Fastest Cache and FVM are disabled and also nothing else is cached or similar.

    Plugin Contributor Aert

    (@aahulsebos)

    Hi @pixelhafendesign,

    Could you try just:

    woowbot-woocommerce-chatbot-pro,

    in the script block for URL’s from scripts needed to be blocked prior to consent.

    Make sure safe mode is disabled.

    If this is done, please let me know so I can have a look.

    regards Aert

    Thread Starter pixelhafendesign

    (@pixelhafendesign)

    Hi @aahulsebos,

    I just pasted your given text and checked the safe mode, it is off. Script is loaded anyway. I leave the settings like this until I hear from you again.

    Best regards
    Marcel

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi @pixelhafendesign could you post a screenshot of your current settings in the script center?

    Thread Starter pixelhafendesign

    (@pixelhafendesign)

    Hi @rogierlankhorst

    I uploaded the screenshots under these two links. The settings are currently set as @aahulsebos had requested.

    https://abload.de/img/screenshot_2021-02-13zrjlo.png
    https://abload.de/img/screenshot_2021-02-13sskaf.png

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    @pixelhafendesign I think the problem is that you have an enter between each string. Can you make this a comma separated list? Like this:

    sibautomation.com,woowbot-woocommerce-chatbot-pro

    Thread Starter pixelhafendesign

    (@pixelhafendesign)

    Madness, this is actually the problem as it looks. You are welcome to look again. The only thing that is now defiantly set by the bot is a PHPSESSID. That doesn’t seem to be able to be blocked. Unless I am possibly overlooking something?

    It would be great if this is made clearer in a future update, how to enter the things in the script center, because I myself have not stumbled across such a hint in the documentation.

    Plugin Contributor Mathieu

    (@paapst)

    Hi @pixelhafendesign, PHPSESSID is a functional (essential/technical) php session cookie. For that kind of cookie, there is no need or legal obligation to block it. https://cookiedatabase.org/cookie/php/phpsessid/

    Thread Starter pixelhafendesign

    (@pixelhafendesign)

    Hi Mathieu,

    thanks for the hint. I have looked at it, it’s good to know.

    I would also like to finally close the issue but it seems that there are more problems with blocking the plugin.

    It’s really very crazy, here’s the scenario:

    Dekstop – Plugin is completely blocked | No chat icon visible (bottom right corner).
    Tablet – Plugin is completely blocked | No chat icon to see
    Smartphone – Plugin is completely blocked so far | Chat Icon shows up all at once, but can’t be clicked until cookies are accepted.

    This can be played through the developer tools with the different screen sizes. Does anyone have any ideas what this could be?

    I am slowly losing my mind.

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    This seems to be an element that is displayed regardless of the javascript. You can hide it with a snippet of custom html, which leverages some body classes that are dynamically added when a user consents:

    #woo-chatbot-chat-container {
        display:none;
    }
    
    .cmplz-status-marketing #woo-chatbot-chat-container {
        display:block;
    }
    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Regarding the documentation: the 5.1 version of Complianz will introduce a new Script Center interface which will make it much easier to manage it.

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.