Support » Plugin: Yoast SEO » URL and logo url errors in Google’s Structured Data Testing Tool

  • Resolved pointbweb

    (@pointbweb)


    When I run The Structured Data Testing Tool on my site, I get two errors “value provided for url must be a valid URL”. The URL and the logo url are both missing the “http:”. I checked the logo entry in the general settings and it is complete with http: and I have no control over the site url as far as I can tell.

    Here’s how the markup comes out:
    <script type=’application/ld+json’>{“@context”:”http:\/\/schema.org”,”@type”:”Organization”,”url”:”\/\/www.ironmaster.com\/”,”sameAs”:[“https:\/\/www.facebook.com\/ironmasterstrength\/”,”https:\/\/www.youtube.com\/user\/IronmasterPro”],”@id”:”#organization”,”name”:”Ironmaster, LLC”,”logo”:”\/\/www.ironmaster.com\/wp-content\/uploads\/2016\/08\/im-logo.jpg”}</script>

    How can I fix this?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support amboutwe

    (@amboutwe)

    Sometimes strange behavior may be caused by a plugin or theme conflict. The fastest way to rule out conflicts is to deactivate all non-Yoast plugins and switch to a standard theme like Twenty Sixteen. If this resolves the issue, you have a conflict and should activate one plugin at a time until you locate the conflict. Finally, after all plugins are active, switch to your theme. This will narrow down the conflict to a specific plugin or theme.

    If you are unfamiliar with checking for conflicts, we wrote a small guide that will walk you through the steps. You can find it here: How To Check For Plugin Conflicts

    Thanks for the reply. That seems to be the answer to any problem in WordPress. I understand plugin conflicts, but this site has a lot of plugins and this issue is so specific to the yoast seo functionality, I thought someone had come across it before or maybe it was a simple configuration setting issue or something. I couldn’t find any other posts or info about it. Assuming you are one of the developers or support reps for yoast, are there no other possible causes you can think of?

    Plugin Support amboutwe

    (@amboutwe)

    I am one of the support team members. I recall seeing something similar when the WP Engine HTML post-processing (feature explained here) included #http://# => // on a users site as a temporary fix for the mixed content warning message when switching to https.

    If you’re not using WP Engine, you may have a plugin or server setting that interacts with the URL, perhaps makes protocol independent URLs, relative URLs, or converts URLs to https.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘URL and logo url errors in Google’s Structured Data Testing Tool’ is closed to new replies.