Support » Plugin: Permalink Manager Lite » Uri not correct on first save of cpt.

  • Resolved joDelicious

    (@jodelicious)


    Hi !

    Here is my problem:

    I have a CPT with the slug event.

    I’m using the permalink manager to change the permalink & URI from /event/xx to /agenda/xx.

    Permalinks are working great.
    But URIs are only good if i save the post twice ! On the first save, the URI stays at event/xx.

    Any idea of what i could try ?

    Thank you !

    Johan

    • This topic was modified 7 months, 2 weeks ago by  joDelicious.
    • This topic was modified 7 months, 2 weeks ago by  joDelicious.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Maciej Bis

    (@mbis)

    Hi Johan,

    does the issue occurs after the post is saved as a draft (the gray button in the top) or published (the blue button in the bottom)?

    Could you send me the sample screenshots with following screens:
    * after the post is saved for the first time
    * after the post is saved for the second time
    * your permastructure settings (/wp-admin/tools.php?page=permalink-manager&section=permastructs)

    Best regards,
    Maciej

    Maciej,

    The issue occurs when the post is saved as published.
    When saved as draft, the uri stays at /agenda/ with no slug afterwards. But it is not my main issue.

    1. After the post is saved for the first time : screenshot

    2. After the post is saved for the second time : screenshot

    3. Permastructure settings : screenshot

    … But now i realize i may be confuse with the URI concept: If i save only once the post as published, and i go to Permalink Manager/ Permalink editor and look at the “Full URI & Permalink”, it is not correct: screenshot

    So, to sum, up: When i published only once, the permalink -looks- fine, but it is not, i need to save it twice.

    Let me know if you need anything more.

    Thank you,

    Johan

    • This reply was modified 7 months, 2 weeks ago by  joDelicious.
    Plugin Author Maciej Bis

    (@mbis)

    Hi Johan,

    it looks like for some reason the “new default” save function URI is not triggered on first time in your case – I will try to recreate the issue and fix it.

    Sorry for all your inconvenience,
    Maciej

    Plugin Author Maciej Bis

    (@mbis)

    Hi again Johan,

    I adjusted the code that is used for “sample permalink” box & “save/update post” action.

    Please download the 1.0.4 dev version (it will be published soon) from here:
    https://downloads.wordpress.org/plugin/permalink-manager.1.0.4.zip

    and install it manually (remove the old instance of plugin before).

    If the issue still occurs, please:

    1. go to wp-admin/tools.php?page=permalink-manager&section=settings and turn on “Debug mode”:
      Debug mode
    2. add a new post
    3. publish it

    In result you will see a debug message that would look like this:
    Debug message

    Please forward it to me with the list of all active plugins on your website (there is a possibility that one of them interferes with my plugin).

    Best Regards,
    Maciej

    Hello Maciej,

    Thank you very much for the update, it is working perfectly.
    I might need further testing but if anything occurs I’ll come back with the debug data.

    Greetz,
    Johan

    Plugin Author Maciej Bis

    (@mbis)

    Hey Johan,

    you’re welcome, 🙂 please let me know if you encounter any further issues.

    Best Regards,
    Maciej

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Uri not correct on first save of cpt.’ is closed to new replies.