WordPress.org

Support

Support » How-To and Troubleshooting » URGENT/Source Flaw: Uppercase class-IXR missing

URGENT/Source Flaw: Uppercase class-IXR missing

  • In WordPress 2.0 there’s a code flaw that prevents the “functions.php”s posting capability.

    After updating to 2.0 and applying all the changes to the view of the site everything ran smoothly until I tried publishing a new Post.

    Opera 8.51 always states the following:

    Warning: weblog_ping(): Unable to access /srv/www/htdocs/web12/html/wp-includes/class-IXR.php in /srv/www/htdocs/web12/html/wp-includes/functions.php on line 843

    Warning: weblog_ping(/srv/www/htdocs/web12/html/wp-includes/class-IXR.php): failed to open stream: No such file or directory in /srv/www/htdocs/web12/html/wp-includes/functions.php on line 843

    Warning: weblog_ping(): Failed opening ‘/srv/www/htdocs/web12/html/wp-includes/class-IXR.php‘ for inclusion (include_path=’.:/usr/share/php’) in /srv/www/htdocs/web12/html/wp-includes/functions.php on line 843

    Fatal error: Cannot instantiate non-existent class: ixr_client in /srv/www/htdocs/web12/html/wp-includes/functions.php on line 846

    (Bolds/Highlights by me)

    Base of the problem was that my ftp client (Total Commander) converted all the files names to lowercase.
    Some part of the code (I don’t know which) is referring to that very “class-IXR.php” (IXR “uppercased”) which is mentioned above. This file is obviously now named “class-ixr.php” (all lowercase) in my installation.

    As I remember from ye goode olde HTML days the file names oughta be all lowercase or at least linked in the right manner. Here it’s linked in uppercase but stored in lowercase. I’ve changed the three letters to uppercase and now everything again works fine.

    I think this is not a major bug but one worth fixing.

    Unexperienced users might not comprehend that error message displayed in the browser and be able to fix one’s problem.

    I’d love to hear from you guys shortly.

    Keep up that awesome work.

    WordPress – giving a voice to the world.

Viewing 2 replies - 1 through 2 (of 2 total)
  • thank you I found two places I had to make the change … I think that fixed it so I can post

    my categories don’t seem to be sticking … I am hoping it is the same issue

    Often the problem is that FTP programs automatically convery uppercase names to lowercase as defult. That happened to me, and I had re-installed wordpress before I realised what the problem was! 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘URGENT/Source Flaw: Uppercase class-IXR missing’ is closed to new replies.
Skip to toolbar