Support » Plugin: Email Before Download » Zero 0kb file downloads

Viewing 10 replies - 1 through 10 (of 10 total)
  • Do you have a URL to your page so I can try it (or can you make a test page)?

    Did it used to work and now it doesn’t or are you basically setting it up for the first time and trying to get it working?

    What is the shortcode you are using?

    Hi,

    Thank you for your reply.

    Actually it used to work properly for several months. But now I have changed the website hosting. And after this change the mentioned problems appeared.

    All downloads from the website are implemented with the Email before download plugin. So the user should fill the form to get the link.

    http://rafasolutions.com/en/download-inpedusavionics-datasheet/

    This is the download link I just created with the form.

    http://rafasolutions.com/wp-content/plugins/email-before-download/download.php?dl=3cf4e298869a47bcfac6d7482d4e15d5

    And these are the shortcodes.

    [email-download download_id=”2780″ contact_form_id=”3342″ force_download=”true”]

    Best regards.

    The best thing to do is:

    make a new form in CF7. Make it the same as your old form, but it needs to be a new form so it gets a new ID.

    Delete the existing download out of Download Monitor.

    Upload the download file into Download Monitor again. You should have a new download ID for it now.

    Go to your page and change your shortcode to use the new CF7 form ID and the new download ID.

    At this point you can try to test again, though you might want to clear the server cache first if you’re using any kind of aggressive server-side caching via some caching plugin.

    I have created new contact form, new download, with new ID.

    http://rafasolutions.com/en/test-download/

    But during created I have noticed new problems, which were not there previously.

    When I was trying to select a file for downloading, it was not possible to select any folder to open, or file o choose.

    So I manually entered file path from the server.

    Next, after the new page with new contact form and new download was created, when I press download, it is opening one of my old contact form for download.

    You can check out it from the provided link.

    When you hit Submit on your test page it is giving a 500 Internal Server Error. Most likely there is an error being logged in an error log somewhere that would give you a clue as to the problem…

    However, that may not be worth tracking down at the moment, since it sounds like you didn’t get the file uploaded the way I wanted. In Download Monitor (which is the “Downloads” link on the wordpress menu) you click “Add New” to add a new file. Type in a title (doesn’t matter what really) and click “Add File” button sort of in the middle of the page (NOT the “add media” button at the top). Clicking “Add File” will expand a panel and then you click “Upload File”. That will throw up the big pop up file box that you’re used to seeing probably. Click on the “Upload Files” tab to get over to the upload part. Click the “Select Files” button in the middle and that will throw up the local file browse popup where you can go find the file you want on your local system. Select the file and submit it to upload. Now it throw you back onto the “Media Library” tab of that popup and your file will upload and it will be selected. Click “Insert File URL” in the bottom right. Now you will be back on the main screen for that download in Download Monitor. Click “Publish” on the right side. Save the “ID” number from the top right area. Just under that is a URL which is the URL that should allow you to access that file from a browser using just Download Monitor (no Email Before Download). Log out or open a new different browser that isn’t logged into your wordpress. Paste that URL in there & make sure you can download the file. If you can, then we know the file is accessible via Download Monitor.

    Now, go back to your test page and replace the download_id with the new download_id from the file we just uploaded and try again.

    In some cases, it is necessary to move the file on the filesystem because the directory is protected. I don’t know if that’s the case for you … I did notice you’re using nginx and I’m not sure how it is configured by default … we’ll see…

    Thank you very much for your help.

    Actually I’m doing exactly the way you described, but the problem is that when I’m opening local browser, it is not allowing me to select a file.

    It seems like to be locked. So I was forced to type the path manually.

    I’m thinking to clear the cache, do you have some suggestions on some easy way of clearing cache?

    Thank you in advance.

    Oh I see what you mean. Ok, well that’s odd but hopefully not a big deal.

    On clearing the cache, it would be in the caching plugin if you are using one probably (like if you were using W3 Total Cache or Fast Cache or whatever). It’s probably not an issue, but just mentioning it.

    How about that URL, did it work? I’m talking about the URL to access the file using Download Monitor (rather than EBD). Again, this is the URL in the top right area of the screen on like the detail type page of the download file (under “Downloads” in the WP menu then edit the download you are testing with and then look in the top-right area for that URL). Post that URL in here.

    Thank you very much for your support. Seems I have found the reason of problems.

    It seems it was the file path issue, as previously the files were kept in the following type of directory

    /home/username/public_html/some_directory/file.pdf

    and now this path became

    /some_directory/file.pdf

    So after this change it is working properly. Also for the PDF type of file, due to Chrome issue with opening files I was using an option “force download”. Somehow this now was also giving issue. After I removed this option, I’m able to download PDF file. But before it was trying to open te file, and was giving an error.

    Thank you again!

    Best regards.

    Glad you got it working.

    My guess is that your previous provider used Apache and your new provider is using nginx and that is the reason for the weirdnesses you saw. That would explain why just moving your existing files (and database) over to the new provider would not work. It might also explain why the problem with Chrome not displaying certain PDFs went away (maybe it’s an interaction between Chrome & Apache and how it handles byte-range requests for PDF files).

    However, I would have expected that to be fixed when you made a new page with new contact form and new upload and made a new shortcode to use on that new page — that should have gotten all new stuff into the database and avoided any lingering old path problems. Oh well, who knows, but glad it works now… good luck.

    Thank you very much for your help. I think you are correct in guessing the reasons.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Zero 0kb file downloads’ is closed to new replies.