Support » Plugin: Ninja Forms - The Easy and Powerful Forms Builder » URGENT: Last update breaks

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi Phil,
    I came looking for support on this issue too. I have now rolled back to the previous version thanks to my backup and all is working again.
    Andy

    yeah – managed to find an old version of the plug in and now back up.

    Going to be much more suspicious of updates from now on – I’ll wait for a bit to see what the errors are.

    It looks v3.2.19 added some extra form validation that fails when you submit a form as a user that isn’t logged into the site. If you sign in as an admin, for example, it works fine.

    That said, they just tagged a new release on GitHub, which I imagine will be available on here soon. Definitely going to be way more suspicious of future “safe” updates.

    DO NOT update to 3.2.20. The plugin was uploaded to WordPress.org incorrectly, and actually appears to contain the 3.2.19 code. I tested it on a test version of one of our live sites, both by updating the plugin and by deleting the plugin and reinstalling it, and both times resulted in the same AJAX error. After checking the plugin files, it looks like the new release is included in the plugin in a “trunk/” folder at the plugin root, but the actual plugin being loaded is 3.2.19.

    Plugin Contributor Zach Skaggs

    (@wpnzach)

    Something broke in WordPress SVN…we’re trying to figure out what went wrong now. The v3.2.20 tag on GitHub WILL work if you need a fix ASAP. https://github.com/wpninjas/ninja-forms/releases

    Plugin Contributor Zach Skaggs

    (@wpnzach)

    Version 3.2.21 is now on SVN and should fully resolve this issue for anyone impacted.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘URGENT: Last update breaks’ is closed to new replies.