WordPress.org

Forums

iframe
[resolved] URGENT iframe not working! (3 posts)

  1. Belindala
    Member
    Posted 1 year ago #

    Hi everyone. I'm having trouble with both iframe html tags or shortcode. Nothing appears!
    This is my code:
    [iframe src="http://www.youtube.com/watch?feature=player_detailpage&v=_M_-2jvUuog" height="300" width="520" allowfullscreen="" frameborder="0"] in visual editor area;
    and surrounded by <div id="video-wrap"></div> in text editor area.
    But there is no video appearing in the post!

    Could someone help? THX!!!

    http://wordpress.org/plugins/iframe/

  2. webvitaly
    Member
    Plugin Author

    Posted 1 year ago #

    You are using direct YouTube link.
    You should use embed YouTube URL for Iframe like this:
    [iframe width="420" height="315" src="http://www.youtube.com/embed/_M_-2jvUuog"]

    If you want to use direct YouTube link - you can use [embed] shortcode like this:

    [embed width="420" height="315"]http://www.youtube.com/watch?v=_M_-2jvUuog[/embed]

    [embed] shortcode is core WordPress feature and does not require any other plugin.

    P.S. [embed] will not work with your YouTube video because it is unlisted. But it will work with all other public videos.

  3. Rachit Singh
    Member
    Posted 7 months ago #

    Go to Your Youtube Video Under share tab Locate Embed Copy the Code paste It in Your post Html.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • iframe
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.