WordPress.org

Support

Support » How-To and Troubleshooting » Urgent Help – Moving WP to local machine

Urgent Help – Moving WP to local machine

  • I have a domain, http://www.rekhaa.net, I want it to move to my local machine. I am using wamp server on windows. I have a folder rekhaa inside www. I took following steps…

    1. Copy all the files to my machine to rekhaa folder
    2. Took the backup of db and replaced all instances of http://www.rekhaa.net with http://localhost/rekhaa and imported it.

    When I run http://localhost/rekhaa, index page opens fine but when I click on posts or page it gives 404 error like

    The requested URL /rekhaa/2008/08/10/babies-born-8808-at-808-8-pounds-8-ounces/ was not found on this server.

    I have tried the options given in the permalink sticky thread but no avail. Even I donwloaded the latest bleed version and upgraded the local installation. Still same problem.

    My htaccess file look like this

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /rekhaa/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Please help.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Is there anybody who can help?

    Well your problem is that the http://localhost/ part isn’t being called in the post. You mentioned you updated you’re permalinks, but what shows up in there?

    You can temporarily fix this problem by adding this to /etc/hosts:

    127.0.0.1 http://www.rekhaa.net

    You’ll probably need to tweak the path to the web pages, perhaps with a symlink.

    You won’t be able to access the real rekhaa.net while this exists. That file location is for a linux box. For Windows, I’m not sure where the file is located.

    Your rewrite rule is inconsistent with the rewrite base. Change the rewrite rule to this:

    RewriteRule . /rekhaa/index.php [L]

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    Also make sure that mod_rewrite is actually enabled on the server.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Urgent Help – Moving WP to local machine’ is closed to new replies.
Skip to toolbar