Support » Fixing WordPress » urgent archive assistance

  • Other than the links on my home page the archives are dead. I’ve entered info on this before here – http://wordpress.org/support/3/4005
    but I was just checking my site traffic and realized that external links in are not found. This are for posts I’d written in MT and imported as well as posts that just no longer appear on my first page.
    The site is – http://www.atmasphere.net/wp archive links are on the right and don’t work. If you search, you’ll get results within the past two months but not through ALL my posts which you should and used to get.
    help, please!

Viewing 15 replies - 1 through 15 (of 28 total)
  • Just hopinng someone will see this post and help me…
    Here’s what I’ve got in .htaccess… I just created an archives folder within /wp and set it to 777. Nothing but file not found for any archive.
    RewriteEngine On
    RewriteBase /wp/
    RewriteRule ^archives/category/(.*)/(feed|rdf|rss|rss2|atom)/?$ /wp/wp-feed.php?category_name=$1&feed=$2 [QSA]
    RewriteRule ^archives/category/?(.*) /wp/index.php?category_name=$1 [QSA]
    RewriteRule ^archives/author/(.*)/(feed|rdf|rss|rss2|atom)/?$ /wp/wp-feed.php?author_name=$1&feed=$2 [QSA]
    RewriteRule ^archives/author/?(.*) /wp/index.php?author_name=$1 [QSA]
    RewriteRule ^archives/([0-9]{4})?/?([0-9]{1,2})?/?([0-9]{1,2})?/?([_0-9a-z-]+)?([0-9]+)?/?$ /wp/index.php?year=$1&monthnum=$2&day=$3&name=$4&page=$5 [QSA]
    RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([_0-9a-z-]+)?(feed|rdf|rss|rss2|atom)/?$ /wp/wp-feed.php?year=$1&monthnum=$2&day=$3&name=$4&feed=$5 [QSA]
    RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([_0-9a-z-]+)?trackback/?$ /wp/wp-trackback.php?year=$1&monthnum=$2&day=$3&name=$4 [QSA]
    RewriteRule ^feed/?([_0-9a-z-]+)?/?$ /wp/wp-feed.php?feed=$1 [QSA]
    RewriteRule ^comments/feed/?([_0-9a-z-]+)?/?$ /wp/wp-feed.php?feed=$1&withcomments=1 [QSA]

    no permalink is working!!

    Why did you create an ‘archives’ folder? That is probably the problem, it interferes witht he mod_rewrite rules. I imagine it was working before you did that?

    You are using a nightly, right? This can be very confusing, since nightlies do change a lot. Try disabling mod_rewrite first, meaning, don’t use the clean url options in WP, then remove or rename your .htaccess file. That should help isolate the problem.

    I did create the folder… after it was not working I thought I’d give that a go…
    I’ll kill the .htaccess and try again. Had not thought to try that

    I currently have no .htaccess and no archive folder and nothing is working.
    I am not sure how else to disable mod_rewrite… do I just select postID?

    OK – disabled… erased and said update. the basic links now work including archives!
    trying again… does not work with an .htaccess file and the re-write options included.

    So it’s fixed now? I don’t understand this last post…

    I can only get the postID – default to work. No rewrite rules are working and (as I think you will recall) that was key in the switch over from MT, not too mention a much nicer way to leave the links.

    Can you explain in detail how you have it set up now and what isn’t working? I’m happy to help, but you have to give more information.

    Thanks for stepping up!!
    What would you like to know?
    If I use any mod-rewrite options, my archives, categories and permalinks all break.
    If I leave mod-rewrite off, all that stuff works, but the urls are not what I would really like to have. Though working is better than not.

    What version are you using?
    What is the format you’ve chosen for your permalinks?
    What are your permalink settings?

    I believe I am running the daily 4/8
    Currently I have the format for permalinks “off” which gets them as the ?p=ID

    I love finding bugs…
    I was shooting for this :
    /archives/%year%/%monthnum%/%day%/%postname%
    If I switch back, do I risk losing anything?

    I reverted back… redid the permalink stuff… dead.
    Not really sure why this won’t work.

    RewriteEngine On
    RewriteBase /wp/
    RewriteRule ^archives/([0-9]{4})?/?([0-9]{1,2})?/?([0-9]{1,2})?/?([0-9a-z-]+)?([0-9]+)?/?$ /wp/index.php?year=$1&monthnum=$2&day=$3&name=$4&page=$5 [QSA]
    RewriteRule ^archives/category/?(.*) /wp/index.php?category_name=$1 [QSA]

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘urgent archive assistance’ is closed to new replies.