WordPress.org

Forums

[resolved] URGENT - All register links are redirecting to login (9 posts)

  1. queenieb
    Member
    Posted 2 years ago #

    My site is http://www.wisdomsistercircles.com/family. I had installed the s2member plugin and later uninstalled it and now my register links don't work. They worked fine before.

    The links should take a new user to http://wisdomsistercircles.com/family/register but instead they are being redirected to http://wisdomsistercircles.com/family/wp-login.php?redirect_to=/family/register/.

    If anyone knows what I need to do to fix this, please help asap. Thanks soooo much.

  2. loughcorrib
    Member
    Posted 2 years ago #

    This may help Have you a cache plugin.If so clear cache and try. Cache can hold settings.

  3. queenieb
    Member
    Posted 2 years ago #

    Tried that...no luck. Any other ideas?

  4. loughcorrib
    Member
    Posted 2 years ago #

    Sorry mean't to state Can you turn off cache temporarily, and ftp to your site look in plugins and ensure that there is no trace of previous plugin there, then turn cache back on. It appears that the plugin set up a redirect and it is still active.Might be worth looking in htaccess also in case it has written something there.

  5. queenieb
    Member
    Posted 2 years ago #

    Thanks @loughcorrib, I deleted 2 s2member folders from the site (using ftp to find them). Didn't see anything in htaccess. It's still redirecting. Any other suggestions?

  6. loughcorrib
    Member
    Posted 2 years ago #

    Here is a temp fix (not ideal)until we sort this out. Go to htaccess copy this to it

    RewriteEngine
    RewriteCond %{HTTP_HOST} ^yoursite.com/oldfile$
    RewriteRule ^$ http://yoursite.com/newfile [L,R=301]

    you only need RewriteEngine on once in the file so if its there already omit it from mine. Fill in your urls above.

    Have to get back to cache again which one are you using and double check ftp in/plugins to see what is there.Would be unusual for this to be hard coded into the php <?php header('Location:http://mysite.net/newpage');?>but life brings surprises
    If you see a similar file in htaccess have a read of it first.
    Did you turn off the cache after any changes "not clear cache"

  7. queenieb
    Member
    Posted 2 years ago #

    Thanks so much loughcorrib...I was with you all the way to the cache. I couldn't figure out how to do that when you mentioned it the first time.

    When you said ^yoursite.com/oldfile$ i'm not sure what the oldfile would be?

    This may be a bit over my head. Perhaps I should just reinstall everything. :(((

  8. loughcorrib
    Member
    Posted 2 years ago #

    Go to plugins and deactivate logout clear browser cache = f5 and then try login
    In htaccess oldfile is where members go to new file is where they should be

  9. queenieb
    Member
    Posted 2 years ago #

    I found the error. The plugin that I installed/removed deselected the privacy option that protected registrations. Once I checked that option, I was able to register new users with no problem. Thanks for your help @loughcorrib. I appreciate your willingness to work with me on this.
    Queenie

Topic Closed

This topic has been closed to new replies.

About this Topic