WordPress.org

Forums

Ready! Ecommerce Shopping Cart
[resolved] UPS Shipping Extension error (6 posts)

  1. utchbe
    Member
    Posted 1 year ago #

    I am not having any luck getting the UPS Shipping extension working with my website or test website. I have gone through the documentation 2 or 3 times and it appears I have everything configured properly. I have a test website up at - http://ma.butchscomputerrepair.com/ with one produce, and I am unable to proceed.

    The response POST response I am receiving is not very helpful to troubleshoot.

    {"code":0,"error":true,"errors":{"payment_module":"You must select Payment Module before continue","0":": "},"messages":[],"html":"","data":[]}

    Any help would be appreciated.

    https://wordpress.org/plugins/ready-ecommerce/

  2. Ready! Developer
    Blocked
    Plugin Author

    Posted 1 year ago #

    Hello.
    Error:
    "You must select Payment Module before continue"
    mean that you must select payment method, select any of your enabled payment methods (as I see - you have "Pay On Delivery", "PayPal" and "Deposit Account")

    Regards,
    Alexey.

  3. utchbe
    Member
    Posted 1 year ago #

    Thanks for your response but that is not the issue. I am selecting a payment method, when I click next with a payment method selected and that is where I am receiving the above error. I went ahead and added a Test Flat Rate shipping option, and that allows me to proceed with no issues. It is only using the UPS extension that I paid for.

  4. Ready! Developer
    Blocked
    Plugin Author

    Posted 1 year ago #

    Hello.
    Please send your request to our internal support system here - http://readyshoppingcart.com/contacts/ - for futher investigation.

    Regards,
    Alexey.

  5. utchbe
    Member
    Posted 1 year ago #

    Awesome, thanks!

  6. utchbe
    Member
    Posted 1 year ago #

    Great help from the developer! Here was the final response in case anyone else runs into this issue.

    Ok, problem is in your CURL php library setup, error is returned on your server is:
    "SSL certificate problem: unable to get local issuer certificate"
    You can check thread for setup guide here http://stackoverflow.com/questions/17478283/paypal-access-ssl-certificate-unable-to-get-local-issuer-certificate (there are actually paypal problem, but same error - in CURL library).
    I made temp fix in /wp-content/plugins/Ready-UPS/ups/mod.php file - disabled SSL verification:
    curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, 0);

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags