Support » Plugin: WP eCommerce » UPS Shipping Calculator Not Working

  • Resolved jtm12

    (@jtm12)


    I’m having trouble getting UPS shipping to work with a new wp e-commerce store. The message the user receives on the checkout page is “Sorry, shipping quotes could not be calculated with the details provided. Please double check your shipping address details.”

    The USPS shipping calculator is working and calculates the shipping for the same items with the same addresses.

    My main question is what throws that UPS message? I don’t know what to look for as a mistake.

    I have tried checking out with many real addresses.

    To set up shipping, I applied for UPS shipping credentials and received an email with those credentials and a note that the account was active immediately.

    I did have a question on whether the username field in your software wanted my “MY UPS” username and password or the “shipping account” username and “MY UPS” password. There’s no “shipping account” password. Since I could edit the shipping account username, which UPS called a description of the account, I made it match the MY UPS username and went with that. It didn’t work with the old username either.

    There are no extra spaces in my credential fields.

    For the shipping origin, I entered “Littleton” and the zip code. I also tried Littleton, Colorado. The USPS calculator works with either entry. The UPS calculator didn’t work at all.

    Other settings:

    Residential address
    Customer counter
    Your packaging
    Singular shipping

    Next day air
    Second day air
    Standard
    (I’ve tried clicking them all, clicking none and clicking various options)

    I did not ask UPS for testing credentials, and I do not have that box checked.

    I also went back into the products and checked weights and sizes. I changed the box sizes to real box sizes from UPS’ website.

    I struggled a bit with the USPS calculator at first. The one tip I will offer on that: If you obtain real credentials from USPS, turn off testing.

    If anyone could steer me toward a potential problem with the UPS calculator, I would appreciate it. Thank you.

    https://wordpress.org/plugins/wp-e-commerce/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Bumping this.. I’ve tried to put in a ticket and contact their customer service 3 or 4 times… silence.

    My issue is similar except the error is “Please select one of the available shipping options. Then we can process your order.” This error pops up despite clearly having selected a shipping option.

    I’ve put in another 10 hours on this and am getting nowhere.

    I’m going to try using another e-commerce store to see if I can get the shipping to work on that.

    I talked with UPS by phone and feel like I have that end of it set up correctly.

    I know the e-commerce part is working because I can get USPS shipping calculations and I can buy something and check out with PayPal Sandbox.

    Either another store will work better or the instructions might help me understand what’s going wrong with UPS shipping on this store. But can’t keep wasting time with the same result.

    UPS is asking for my site’s XML requests and responses when the UPS shipping calculator fails.

    In test mode, I see these XML requests and responses on the checkout page.

    I tried making a PDF of the page and giving it to UPS but was told that was insufficient.

    Since these requests and responses are part of the free plugin, I’m assuming there’s documentation telling developers how to use these or submit them to UPS. Would someone provide a link to this documentation?

    Thank you.

    The UPS shipping calculator in wp e-commerce worked perfectly once I moved it to a live website. If you are having trouble in a local environment, try it online.

    And if that doesn’t work, the premium shipping calculator by Auction Inc. worked perfectly on the first try (locally, too). It does not require users to set up accounts with UPS and USPS.

    I hope this helps someone else.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘UPS Shipping Calculator Not Working’ is closed to new replies.