Support » Fixing WordPress » Uploads Folder / Images dissapeared?

  • Hi,

    I removed the uploads folder today and re-uploaded it with all my images, but now I get no thumbnails?!
    In the media library the images are listed but no images exist, also the images appear within the posts on my site but not as thumbnails on the main page???


    Please help!!


Viewing 6 replies - 1 through 6 (of 6 total)
  • You say you removed it and then re-uploaded it…

    1. Does the directory that you re-uploaded contain exactly the same files and structure as the directory that you removed?
    2. Does the directory that you re-uploaded exists at this address: /wp-content/uploads/ ?
    3. What was you reasoning for doing this in the first place?
    4. Do you have a link to your site and you uploads directory?

    Yes it contains all the exact same files.
    Yes, exists at same address.
    My reason was that when trying to upload a image, it was giving me an error: Cannot move file to wp-content/uploads/

    So, I created a new folder called images and pointed the image uploader to there. That worked fine.
    But then I had no thumbnails.

    I’ve even uploaded images to the new wp-content/iamges/ folder and still the thumbnails do not show? Yet the images within the actual posts are showing – and linked from the originail wp-content/uploads/ folder?!

    Strange huh


    Very strange indeed. I see that you are using tim-thumb for your thumbnails and that the php script that creates and displays the thumbnails is throwing a php error:

    <br />
    <b>Warning</b>:  touch() [<a href='function.touch'>function.touch</a>]: Unable to create file ./cache/0c45e49604d7b57da275782c45eb9776.png because Permission denied in <b>/wp-content/themes/church_40/tools/timthumb.php</b> on line <b>236</b><br />
    <br />
    <b>Warning</b>:  Cannot modify header information - headers already sent by (output started at /wp-content/themes/church_40/tools/timthumb.php:236) in <b>/wp-content/themes/church_40/tools/timthumb.php</b> on line <b>246</b><br />

    I would check the permissions on the timthumb cache folder and make sure that the script can write to it.

    Also, if you view the source of your homepage you will see that tim-thumb is looking for the thumbnail in /wp-content/images/ – which is correct.

    I think that your main problem stems from incorrect file permissions. I would guess that originally you /uploads/ directory was not writable by WordPress but when you created a new folder “images”, it possessed the proper permissions. I think that tim thumb’s cache folder is suffering from the same dilemma.

    Hope this helps,

    The uploads folder has been writable until last week?! Because this site is worked on almost daily and had no problems last year. Also the timthumb is incorporated within the theme I am using.

    I have changed the permissions on the timthumb folder and actual timthumb.php script – I changed it all to 777, then back to 755 and it all seems to be ok now?!

    wp-content/header-images/ is not writable or does not exist.
    we created the file in WP-content and under properties it is checked writable, and still it gives this error, and will not let upload an image, this would be cool if we can get it to work……..

    we have took the plug in out for now, looks you guys some bugs to work out…….i will watch for updated versions

    will nice to have

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Uploads Folder / Images dissapeared?’ is closed to new replies.