Support » Fixing WordPress » upload/insert media issues with 2.7, FF, Mac

  • Hello, this is my first post and I’ve done countless searches so please bear with me; I’m kind of new to this.

    I’ve done every applicable thing in this sticky post and I’m still experiencing issues with upload/insert media.

    Here is a screenshot (tiny url link) of what I’m seeing in the visual editor. As you can see, the icons are not visible, however the links for said icons are working. The icons are in my directory. Everything shows up fine in my code. When I click the empty space where the icon should be, a blank, white pop-up window appears. It seems many people are having this problem, but most are able to fix it; I am not.

    This only happens in Firefox (3.0.5). Upload/insert runs normal when tested in Safari (3.2.1). I am running Mac OS X 10.5.5 and have Flash 9 (9,0,45,0).

    I don’t have any uppercase characters in my URL or any directory on my server; and everything looks as it should in my Settings.

    I’ve completely deleted wp-admin and wp-includes folders, downloaded them from wordpress, and uploaded them to my server. Still having problems.

    Any new tips would be most appreciated; I don’t want to use Safari every time I create a new post that includes media.

    Thanks!!
    –Regina

Viewing 15 replies - 1 through 15 (of 15 total)
  • Trying adding the following to /wp-admin/.htacess

    <IfModule mod_security.c>
    SecFilterInheritance Off
    	<Files async-upload.php>
    		SecFilterEngine Off
    		SecFilterScanPOST Off
    	</Files>
    </IfModule>

    Create the file if it doesn’t exist…

    @musnake, I’ve done that too. Still not working 🙁

    bump plz

    How odd. Maybe a FF addon conflict?
    Do you use Google Gears?

    I am using Google Gears. It’s not a FF add-on conflict because I’ve disabled/uninstalled all of them during testing and the problem persists.

    I’m so frustrated. I’ve probably done hundreds of searches trying to resolve this and I’m getting nowhere.

    bump again.

    I have this same problem. It’s only on the new blog I just installed a couple of weeks ago. The rest of the WP blogs on my VPS are just fine. I can add media from the media library, but not event he Upload/Insert shows for me.

    I was running Gears in FF but I’ve uninstalled it. I also don’t see the Upload/Insert or the associated options in IE. I added the code to .htaccess and still no go.

    I would also love to find a solution to this problem.

    this problem is driving me crazy. doesn’t work with safari and FF either (mac).

    got to deliver the finished corporate blog to a customer the next week. anybody found a solution? 🙁

    I was lead here from http://core.trac.wordpress.org/ticket/8806. This bug is different than the one described there.

    Did anyone fix this?

    hey yall,
    was having the same issue with this.
    turns out (for me anyway) the issue is user role related and not browser related.

    the upload/image toolbar disappeared for me completely when i assigned a user to be a contributor, but reappeared under other higher level roles.

    FF (5.0), safari (3.2.1), OSX 10.5.6, FlashPlayer 10, WP 2.7.0

    elreverend

    (@elreverend)

    I have the same problem, since version 2.5 (!) in Safari, Firefox, but NOT Camino. In both local development area AND on my live site. There are enough posts out there, but none with a definite answer. I followed various suggestions, but without positive result.

    So while the image/upload links still work they are not visible in the browser. However, if you switch to fullscreen editing mode they do appear.

    I’d appreciate any help.

    shavityoav

    (@shavityoav)

    Hi,
    I found the solution to this problem after very long (very very) time.
    It’s so simple, I’m shame to explain:
    You have to check if the URL for the installation do not have any
    CAPITAL letters.
    * You can change this URL at the settings panel

    I had! When i change it to be without any CAPITALS it works

    Whoopee
    Hope this is also your bug

    I’m having the same problem.

    Admin gets the Upload/Insert text and the four little buttons.

    BUT

    Users who log in at the lowest access level do not.

    They can add video, text, special symbols, etc. All the stuff that’s in the “kitchen sink” tool bar.

    But not what’s supposed to be next to words that say Upload/Insert.

    I can’t assign users to a higher level. I need them to be able to insert photos.

    I’m either just going to up the default user level to Author from Contributor, or require that they link to images and media on other servers at the Contributor level.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘upload/insert media issues with 2.7, FF, Mac’ is closed to new replies.