Support » Fixing WordPress » Uploading to media library through dashboard causes 500 internal server error

  • I need to upload a PDF to my media library for use in a post, but when I upload it through the Media Library/Add New, it shows a 500 Internal server error whenever I click a link that should show the PDF. There are PDFs that were on the site previously that still work when I view them, it’s only a problem with files that I try to upload now.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    Hi @jrkreke

    Does this happen on all browsers?

    Have you tried deactivating all plugins to see if that helps resolve the issue? Are you able to access the error_logs, if not you can ask your hosting company about where those reside.

    Hi,

    I also came across the same issue.
    I have tested this on Microsoft Edge and on Chrome, and it fails for both.
    When I go to check link for the documents (.pdf in my case), it throws the following error:
    “500 – Internal server error.
    There is a problem with the resource you are looking for, and it cannot be displayed.”

    I have checked the debug.log file and its empty. No other trace of error.
    I have also tried deactivating and re-activating Plugins (one at a time) as well, but with no luck.

    The WordPress version I am using is 4.8.

    Can anyone help in this regard, Please?

    Thank you in advance,

    Somdip

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Uploading to media library through dashboard causes 500 internal server error’ is closed to new replies.