Support » Fixing WordPress » Uploading to gallery in wordpress 3.0

  • Hi there

    I’ve just upgraded to version 3.0 and made my first post. I’m trying to upload to the galery so that I can insert my images into the post. The iframe no longer comes up and instead opens a page to upload. I’ve uploaded my image to the gallery clicked “insert into post.”

    After which, i come to a blank page and doesn’t return me to the edit post page.

    Help anyone?

Viewing 15 replies - 1 through 15 (of 15 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems?

    – increasing the available memory?

    I’ve tried all those. All my plugins are working fine and my theme isn’t causing any problems. I’ve increased the memory with Memory Bump and I’m still having issues.

    I’ve done the same to another WordPress install on the same server and it’s working fine. For my main blog, the system won’t let open up the iframe to let me upload images and insert them.



    Forum Moderator


    resetting the plugins folder by FTP or phpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress 3.0

    I’m also suffering this issue.

    I deactivated all my plugins and re-tried the process – same thing occurred.

    Also tried the above of resetting the plugins folder, no luck there either.

    I’m having the same issue as OP. I have re-installed wp-admin and wp-includes fresh (delete/ upload) to no avail, also tried the re-install from the admin-page.

    When I mouse over (and see URL for) the image uploader, I see:

    On a site that works I see:

    It seems as though the issue is that the “&width=640&height=802” is not being appended on the broken WordPress installation.

    I don’t know the answer but hopefully that helps troubleshooting efforts.

    I am having same problem and can’t upload my images in my posts since last 2 days. I hope anyone will come up to help us.

    I. So I just tried (again):
    1. rm -R
    2. rm -R
    3. cp -R
    4. cp -R

    That didn’t work.

    II. Disabled all plugins

    That didn’t work.

    III. I did the plugins shuffle/ reset as described in the link above

    That didn’t work.

    IV. Changed Themes cycling through default themes

    That didn’t work. (but some users that got to see 3 different themes on a visit)

    V. Memory fix listed above

    That didn’t work.

    Anyone have any thoughts?

    My problem has been solved! I did ask for a help to my host and they helped me nicely.

    Any of your plugin could be caused of this issue. Disabling that plugin allows the posts page to function properly once more. It’s a strong possibility that any of your plugin may simply not compatible with version 3.0 of WordPress at this time, or that it is not going to work in conjunction with another of the plugins that you are using for the site.

    So contact your host as they can help you the best for this issue.
    Good luck!



    I disabled all plugins. Any idea of what plugin was causing your issue?



    Forum Moderator

    Any of your plugin could be caused of this issue.

    And this is why I suggested deactivating all plugins at the top of this thread…

    @pjk: Did you try resetting the plugins folder by phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.



    @sekatsim: that worked. you rock! thanks!!!!!!!



    WordPress 3.0 Image Upload Problem : Tagaroo Plugin

    I deactivated Tagaroo which is a pretty popular plugin and the image upload problem was fixed

    I had a similar problem and after with uploading. My fix was related to me having moved my WP files to a new folder on my server. I then used a backed up version of the database. All else was running smooth except the MU function. I also tried the plugins and theme etc. Finally I found that in my settings tab there is a media page. Here I found ‘Store uploads in this folder’ and it shows the folder path it uses when attempting to upload your media files.

    In my case it had a legacy server path from my old install. Seeing that this post refers to an upgrade it may pay to check that the path in this field is pointing to the right folder.

    Of course I then checked the folder on the server that the previous path showed to and lo and behold there was a folder full of duplicate images that I was trying to upload.

    Hope this helps.

    ‘Social Discussion’ plugin broke image uploading for me.

    But how does a plugin break core wordpress functionality anyway?

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Uploading to gallery in wordpress 3.0’ is closed to new replies.