Support » Fixing WordPress » Uploading pictures to the Media Library: “Specified file failed upload test.”

  • I am on WP 5.1.1. I changed my domain this week and lost most (but not all) uploaded pictures in the Media Library. When I try to re-upload them I get, “Specified file failed upload test.”

    I’ve enabled the following settings in wp-config.php but am not seeing any debug output in debug.log:
    define(‘WP_DEBUG’, true); define( ‘WP_DEBUG_LOG’, true ); define( ‘WP_DEBUG_DISPLAY’, true );

    There’s also no debug output in either the Apache or PHP error logs.

    I’ve run Health Check and disabled all plugins but it’s still doing it. I’ve installed mod_security but tried the same with SecRuleEngine Off. I’ve installed Wordfence as well but it was disabled during the Health Check test.

    I tried this in the .htaccess, no good:
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>

    Also, the browser uploader option silently fails. Tried the WP Health plugin and it says everything is good.

    The wp-content/uploads directory’s permissions are 750. Tried 755.

    This may or may not be important: My WP install is linked to my WP account. I wonder if the domain name change boogered something up.

    What else can I look at?

Viewing 7 replies - 1 through 7 (of 7 total)
  • (Moved comments to OP. Mods if you would be so kind please delete this reply and the following one.)

    franciscogarciahidalgo

    (@franciscogarciahidalgo)

    Intento cargar imágenes en la entrada de mi blog y me da una y otra vez error de carga. Son fotos hechas con el teléfono móvil, en otras entradas tengo fotos hechas con la cámara digital y no me dio error cargarlas, ¿alguien puede ayudarme?

    Fixed 🙂 I had set file_uploads = Off in php.ini.

    kumarsarvesh

    (@kumarsarvesh)

    “Specified file failed upload test”.- I am receiving that message when uploading a file. help me to fix this issue. I tried with everything by removing all plugins, etc. but unable to fix it. help me

    What is your file_uploads setting in php.ini set to?

    kumarsarvesh

    (@kumarsarvesh)

    php.ini doesn’t exist

    Has to exist somewhere or you won’t be able to run WordPress at all. Run one of these. If no results or if you can’t run them ask your systems administrator.

    find /etc -name php.ini
    locate php.ini

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Uploading pictures to the Media Library: “Specified file failed upload test.”’ is closed to new replies.