WordPress.org

Forums

[resolved] Uploading Media Shows Outline with Red Cross (8 posts)

  1. mickyfen
    Member
    Posted 4 years ago #

    Hi All,

    I've tried to find a solution in other areas but I'm getting stuck.

    I'm running http://www.jeffandmick.co.uk and everything has worked perfectly until today. I wanted to change my logo in the header of my Arras Theme blog and went to upload a new image. The site told me that changes were succesful and when I looked back at the uploaded imageit diaplyed the outline but with a red cross in it. If I try to upload media it also does the same thing. This was working perfectly before. I tried to diasble my plugins but that hasn't helped. I'm stuck and can't find a way forward. ANy help is appreciated.

    Mick

  2. threestyler
    Member
    Posted 4 years ago #

    check the folder permissions of your upload folder are 777.

  3. mickyfen
    Member
    Posted 4 years ago #

    Thanks for the suggestion. I've tried that and still get the red cross showing in the thumb of the upload and when inserting new media / images into post.

  4. mickyfen
    Member
    Posted 4 years ago #

    If i go to edit image I can see the picture but it appears in a different size (cropped) to the one that I uploaded and the thumb still shows as a the image border with a red cross.

  5. mickyfen
    Member
    Posted 4 years ago #

    I've linked in two screen shots to show what I mean

    http://www.jeffandmick.co.uk/wp-content/uploads/one.gif

    http://www.jeffandmick.co.uk/wp-content/uploads/two.gif

    Hope that helps someone to help me sort it out?

  6. mickyfen
    Member
    Posted 4 years ago #

    This hasn't been resolved by upgrading to 3.0

  7. Diesel9a1
    Member
    Posted 4 years ago #

    Same problem here. It was working, then I upgraded to version 3, and it stopped working. I totally deleted all WordPress stuff (I haven't lost any work as I haven't done anything yet!). Re-installed, then upgraded. Still no joy with the thumbnails.

    I'm a total newbie to wordpress, so struggling to help with any info.

  8. Diesel9a1
    Member
    Posted 4 years ago #

    I have changed a line in my .htaccess file:

    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-content/blogs.php?file=$2 [L]

    to

    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    and it has fixed the issue. Not sure if it is a coincedence but it is working again.

    My full htaccess file is:

    SetEnv DEFAULT_PHP_VERSION 5
    RewriteEngine On
    RewriteBase /blogging/

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

Topic Closed

This topic has been closed to new replies.

About this Topic