Uploading media fails due to permissions issues with MultiSites enabled. (1 post)

  1. digitaldarragh
    Posted 3 years ago #


    When trying to upload media using either the flash or browser method messages informing me that the upload has failed are shown. These issue revolve around the permissions of /wp-content/blogs.dir/2/files/2012/09/. I have manually created this path and have given it the required permissions.

    I think this is likely an issue with my .htaccess but I'm not sure exactly where the issue lies.

    I have tried giving the www-data account, the root account and the sites FTP accounts access to this. Still no success.

    Although not particularly secure, I have also set all permissions to Read / Write. (777).

    .htaccess file shown below:
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    There are no errors in the Apache access or error logs.

    Any suggestions? I'm under pressure to get this resolved quickly so any help would be really appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic

  • RSS feed for this topic
  • Started 3 years ago by digitaldarragh
  • This topic is not resolved
  • WordPress version: 3.4.2