Support » Fixing WordPress » Uploading media error (wordpress 4.9)

  • Hello,

    I just uploaded wordpress to 4.9 and since then I have been getting errors on uploading new media. I don’t know if it is an HTTP error since it only says “An error occurred in the upload. Please try again later”. I would like to know how could I keep uploading media as always.
    Thank you,

    Miguel

Viewing 13 replies - 1 through 13 (of 13 total)
  • Moderator t-p

    (@t-p)

    See if this tutorial point you in the rifgt direction http://www.wpbeginner.com/wp-tutorials/how-to-fix-image-upload-issue-in-wordpress/

    I am getting the same error. Everything worked fine before 4.9. I didn’t change any file or folder permissions, and one jpg file did upload post update. But I’ve been trying and no further images will upload, several reach 70%, and 84% etc, but then eventually return a HTTP Error.

    The fact that one image did upload tells me it’s not a permission error.

    I have also tried both the multi-file and single file upload methods, neither work.

    • This reply was modified 1 year, 8 months ago by  jamieedwards.
    • This reply was modified 1 year, 8 months ago by  jamieedwards.

    I checked a couple of different server logs for errors and see nothing. I turned on WP_DEBUG and no errors on the media uploads. It’s strange, I’ve been messing with this for the past few hours and have been able to upload a total of 6 images (each jpg image is under 1mb). Probably tried 30-40 times, so it does work very occasionally.

    I’m on RHEL and I checked /var/log/messages and I also checked my website root log.ssl log. No errors, strange…

    As I was typing this post I tried uploading 4 images using the multi-file upload. The first 2 images completed right away, and the third one is stuck at 72%, fourth image 0%.

    Yes it is weird because in some way I can see that some images did upload but just when I view the media as a list (When I change the view of the media it just keeps loading the page). But when I’m trying to use this images as featured images for a page I can not see them.

    Yeah, that’s because they aren’t actually being uploaded.

    Just to note, this is happening with all plugins disabled and running the Twenty Fifteen theme running on WordPress Multisite.

    • This reply was modified 1 year, 8 months ago by  jamieedwards.

    Figured out the issue for me. It was my antivirus software. I am running Avast, I disabled it, everything works now!

    Moderator t-p

    (@t-p)

    Thanks for reporting 🙂

    I don’t even have antivirus, I am able to use some images even with the uploading error. But I can’t change my header image.

    I’ve the same problem after update to last version of WordPress.

    Same issue here… not signs of errors in the logs. I’m running 4.9.1.

    +1 I’m running 4.9.2

    Hi,
    I have added metaboxes in post.
    I created a folder metas which contains functions.php file with a class and a public __construct for my different metaboxes.
    My template functions.php file requires this metas folder functions.php.
    When my metaboxes are activated, I can’t upload files (images) or plugins.
    I glance at the debug log:

    07-Mar-2018 13:08:44 UTC] PHP Stack trace:

    [07-Mar-2018 13:08:44 UTC] PHP 1. {main}() C:\wamp64\www\mbn\wp-admin\post.php:0

    [07-Mar-2018 13:08:44 UTC] PHP 2. setcookie() C:\wamp64\www\mbn\wp-admin\post.php:198

    [07-Mar-2018 13:08:44 UTC] PHP Warning: Cannot modify header information – headers already sent by (output started at C:\wamp64\www\mbn\wp-content\themes\twentyfifteen\metas\functions.php:51) in C:\wamp64\www\mbn\wp-includes\pluggable.php on line 1216

    Can you help me.

    Thanks

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Uploading media error (wordpress 4.9)’ is closed to new replies.