Support » Fixing WordPress » Uploading images – warnings…

  • Hi, I’ve been trying to add images to my WP blog using the “Upload New Media” function. I’m using GPP’s Workaholic theme and whatever I do, keep on getting the same error messages. After all this, the images are on the server and are more or less usable. Added to this, I cannot seem to use the image edit function – as in just getting the hour glass when I try to edit an image. The question to ask I suppose is, is this a server side issue or something wrong with the type of images I’m uploading as in JPEG of around 2 Mb in size or an issue with WP? This is a new installation. Would appreciate some feed back on where to look or go to resolve this issue.

    The error messages I get are these:
    Warning: imagecreatetruecolor() [function.imagecreatetruecolor]: Invalid image dimensions in /home/###/domains/xyz.com/public_html/photoblog/wp-includes/media.php on line 1008

    Warning: imagecopyresampled(): supplied argument is not a valid Image resource in /home/###/domains/xyz.com/public_html/photoblog/wp-includes/media.php on line 423

    Warning: imagejpeg(): supplied argument is not a valid Image resource in /home/###/domains/xyz.com/public_html/photoblog/wp-includes/media.php on line 453

Viewing 4 replies - 1 through 4 (of 4 total)
  • lbrown77

    (@lbrown77)

    Hi, did you ever find a solution for this? I’ve just experience the same issues.
    I would appreciate any help you can offer.
    Thanks

    Moderator Kathryn

    (@zoonini)

    Be sure your files are under 2 MB in size.

    lbrown77

    (@lbrown77)

    File sizes are fairly small, they vary between 40kb – 150kb.
    I’ve been digging around for days trying to fix this. I think the issue is related to some images being portrait, as landscape uploads fine.
    The error i receive is the exact same as the one above.
    I’ve tried a fresh install of WordPress and the theme and database – with no luck.
    I followed the install instructions for the theme (http://demo.graphpaperpress.com/wp-content/themes/workaholic/instructions.html) and thought leaving the image height blank could be the issue, but adding a value here doesn’t help resolve this.
    Any help you can offer would be great.

    Moderator Kathryn

    (@zoonini)

    lbrown77, do you mind starting a new thread for your issue, please? Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Uploading images – warnings…’ is closed to new replies.