WordPress.org

Support

Support » How-To and Troubleshooting » Uploading images fails — Read error in image.php

Uploading images fails — Read error in image.php

  • Dear all,

    I am getting the following error lines, not documented in the sticky:

    Warning: getimagesize() [function.getimagesize]: Read error! in
    /home.10.16/myblog/www/blog/wp-admin/includes/image.php on line 143
    >
    Warning: getimagesize() [function.getimagesize]: Read error! in
    /home.10.16/myblog/www/blog/wp-admin/includes/image.php on line 17
    >
    Warning: imageantialias(): supplied argument is not a valid Image resource
    in /home.10.16/myblog/www/blog/wp-admin/includes/image.php on line 44
    >
    Warning: getimagesize() [function.getimagesize]: Read error! in
    /home.10.16/myblog/www/blog/wp-admin/includes/image.php on line 46
    >
    Warning: Division by zero in
    /home.10.16/myblog/www/blog/wp-admin/includes/image.php on line 64
    >
    Warning: imagecreatetruecolor() [function.imagecreatetruecolor]: Invalid
    image dimensions in
    /home.10.16/myblog/www/blog/wp-admin/includes/image.php on line 68
    >
    Warning: Cannot modify header information – headers already sent by (output
    started at /home.10.16/myblog/www/blog/wp-admin/includes/image.php:143) in
    /home.10.16/myblog/www/blog/wp-includes/pluggable.php on line 390

    It seems the first error is causing the others. It happens with all images.

    Line 143 in image.php reads:

    $imagesize = getimagesize($file);

    Any idea what’s wrong here?

Viewing 11 replies - 1 through 11 (of 11 total)
  • A “read error” essentially means that the file did not get uploaded. There’s all sorts of reasons for this, unfortunately, we can’t diagnose them. You need to look in the PHP error logs and figure out what the problem is there.

    In short, it’s a PHP or webserver configuration error. Can’t help you on that one, much.

    Thanks for the reply; How do I read such logs please?

    (Nothing was changed on my webserver in the last months; perhaps it could be that I maxed out my space on my webhosting platform?)

    Thanks for the reply; How do I read such logs please?

    That really can’t be answered. Different host, different log setups. And only you can tell if you maxed out the space or not.

    I assume by your message it worked before and stopped out of no where?

    Absolutely, it stopped working out of nowhere and I have a huge quota at my webhost. The webhost has not updated PHP either, so I really am at a loss hereā€¦

    How do I read such logs please?

    Yeah, see, that’s one of those seemingly simple question which has a profoundly complicated answer.

    The short version is, you don’t. If you’re not running your own server, then you probably don’t have enough access to do that. You’ll have to take it up with your webhost.

    Did you recently upgraded or anything?

    No, nothing upgraded recently.

    I’ll call my webhost tomorrow, I wonder what they are going to tell me.

    What I feared was going to happen, happened: the webhost blamed WordPress. Stalemate.

    Time to find a new webhost then, because a “read error” is definitely not WordPress.

    I have documented the issue on the help forums at the concerned ISP.

    Someone suggested this is a consequence of an Apache update which inadvertently increased security settings, and this sounds intuitively like a good explanation.

    Now I am going to spend time on the phone with OVH, who is not being very smart about the issue, telling me instead WP is to blame (something I never seriously suspected myself).

    Problem solved: The webhost suddenly decided that I had maxed out my FTP quota. Of course it took me two phone calls to get the information (the first operator told me everything was fine, accusing me and my installation to be the problem), and of course I had no means to get this information myself since their user-side FTP quota CGI script has been broken for ages.

    Now for a final rant, that’s what you will get from OVH as a webhost: low-quality service with an inexistent help desk and clueless script programmers.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Uploading images fails — Read error in image.php’ is closed to new replies.
Skip to toolbar