Support » Fixing WordPress » Uploading Images

  • I am trying to upload an image to my WordPress blog. When I attempt to. I get a message that say, ” Unable to create directory wp-content/uploads/2016/06. Is its parent directory writable by the server?” I have search for a remedy for this problem all over the Internet. I keep finding what other people have done to resolve the problem to upload an image. They say see process below:

    •Sign in your WordPress admin Panel.
    •Go to Media Settings menu (Settings =>> Media).
    •Enter wp-content/uploads with labeled “Store uploads in this folder” text box.
    •Click on the “Save Changes” button to save the changes and you are done.

    When I attempted to do this. There is no Enter “wp-content/uploads with labeled “Store uploads in this folder” text box.” that appears. It just shows some image size to select and a box to check that says, ” Organize my uploads into month- and year-based folders”

    Will someone please tell me what I have to do so I can get my images to appears in my blog post?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Go to “Settings” in the left hand column of your wp-admin page. Select “Media”. You should then have the “Media Settings” page. First there are “Image Sizes”. Below that it should show a section titled “Uploading Files”. Here you should see “Store uploads in this folder” with a box. In this box it probably should have entered ” your home directory whatever that is/public_html/wp-content/uploads ” Check that this is what is entered here. Underneath that you can optionally add the “Full URL path to files though you can leave it blank. If you complete it it should be “http://yoursite.com/wp-content/uploads” Then if you check the box “Organise my uploads into month- and year-based folders”, WordPress ought to create a folder based on the month to upload your files to.

    I see the section that say, “Uploading Files.” After that I have ” Organize my uploads into month- and year-based folders” with a check box(I have that box checked). Then under that I only have the option to save. Don’t have, “Store uploads in this folder” with a box” on this page.

    It should look similar to this

    media settings

    My path is slightly different to the default for another reason.

    If you don’t have the ability to specify the uploads folder like this, then I don’t know why not.

    • This reply was modified 4 years, 4 months ago by bill7473.

    Click on link below. Having trouble posting an image

    image

    • This reply was modified 4 years, 4 months ago by bill7473.

    Thanks for the assistance. But I’am still trying to figure out way I can’t post images. Hopefully this page I came across will help me.

    https://codex.wordpress.org/Settings_Media_Screen

    That’s because PHP process is running under nobody user. Contact your host or coder to fix this issue on your server.

    I am not a techie. What do you mean “nobody user?” I am using Godaddy. What do I ask host about this problem? I am running a localhost using MAMP PRO, if that means anything.

    Typically, all files should be owned by your user (ftp) account on your web server, and should be writable by that account. On shared hosts, files should never be owned by the webserver process itself (sometimes this is www, or apache, or nobody user).

    Any file that needs write access from WordPress should be owned or group-owned by the user account used by the WordPress (which may be different than the server account). For example, you may have a user account that lets you FTP files back and forth to your server, but your server itself may run using a separate user, in a separate usergroup, such as dhapache or nobody. If WordPress is running as the FTP account, that account needs to have write access, i.e., be the owner of the files, or belong to a group that has write access. In the latter case, that would mean permissions are set more permissively than default (for example, 775 rather than 755 for folders, and 664 instead of 644). Source, Source 2

    This may help you: Try changing wp-content file permission to 777, and once you can upload image, change it back to 755. Source

    If you still seeing the same issue, then you should contact Godaddy and ask them that your account is running under nobody user. As its a hosting issue, you can only play with file permission.

    Found another solution from this thread: Try adding the following to the top of your .htaccess file hope this solved the image upload problem:

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>
Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Uploading Images’ is closed to new replies.