[resolved] Uploading images (5 posts)

  1. HannaIsabella
    Posted 8 years ago #

    I know there was a topic like this but I couldn't get any help from that one so I made a new one. I can't upload images to my blog, I get an error massage saying that the file couldn't be moved to the wp-content folder. I'm quite confused about this since it's working on my other blogs but not on this one hannaisabella.com/

    I'm not very good at this whole php thing since I've only had my blog for two days, so an easy explanation would be nice since I don't understand that much.

    This is the error message I get:
    "Unable to create directory /home/xxxxxx/public_html/blogg/wp-content/uploads. Is its parent directory writable by the server?

  2. Phil Egan
    Posted 8 years ago #

    I'm experiencing the exact same problem. Have you found a solution now?

  3. Phil Egan
    Posted 8 years ago #

    It's okay... I solved it!

    Using cPanel, I changed the file permissions on my wp-content folder to 777 (it was previously 755). I'm now able to upload images as required.

  4. mjhasley
    Posted 8 years ago #

    Phil.... how do you do that?

  5. Phil Egan
    Posted 8 years ago #

    I can tell you how I did it in cPanel - so if you have that here is what I did...

    In cPanel I went into File Manager (if you are presented with options for which directory to open, I chose Web Root (public_ftp)

    I navigated to my blog folder on the left and clicked on it so the contents are displayed in the main right hand panel.

    I clicked on the square next to the wp-content folder, to select it.

    I then clicked on "Change Permissions" in the top menu bar of File Manager.

    In the "Change Permissions" window that appears, the boxes next to "Write" were unchecked in "Group" and "World".

    I simply checked those two boxes so that all the 9 boxes were checked and the values in the Permission boxes were all at "7".

    I clicked "Change Permissions" in the bottom of this window and came out of File Manager.

    When I tried again to upload an image, it went in no probs.

    I hope that helps.

Topic Closed

This topic has been closed to new replies.

About this Topic