WordPress.org

Support

Support » How-To and Troubleshooting » uploading images

uploading images

  • Last night on version 3.1.4, this worked fine, then I upgraded to the latest version and it no longer works.

    I am using a theme that has additional fields so it can be used as a real estate theme. Some of these fields are for additional photos. I click on “upload” and I’m able to upload the photo just fine, but when I click on “insert into post”, nothing. Before upgrading WP, it would put the URL of the image in the text box next to the upload button, now it just stays blank.

    Any ideas how to fix this?

    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator kmessinger

    @kmessinger

    Forum Moderator

    Have you tried:

    – deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). Don’t forget the ones in mu-plugins. If you can’t get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    If I switch the theme, I don’t have the additional upload image fields.

    I’m not using any plugins.

    Seems it’s triggering mod_security:

    Pattern match “=(http|www|ftp)\:/(.+)\.(c|dat|kek|gif|jpe?g|jpeg|png|sh|txt|bmp|dat|txt|js|html?|tmp|asp)\x20?\?” at REQUEST_URI. [file “/usr/local/apache/conf/modsec2/rootkits.conf”] [line “3”] [id “390144”] [rev “1”] [msg “Rootkit attack: Generic Attempt to install rootkit”] [severity “CRITICAL”]

    GET /wp-content/themes/ElegantEstate/timthumb.php?src=http://photos3.zillow.com/is/image/i0/i7/i8441/IS1omtiwbewfrtv.jpg?op_sharpen=1&qlt=90&hei=234&wid=316&w=373&h=306&zc=1 HTTP/1.1

    Moderator kmessinger

    @kmessinger

    Forum Moderator

    You switch themes briefly to see if you can insert one image. Then you switch back.

    Actually, I removed that image in the error, and none of the others are producing that, so it isn’t caused by mod_security.

    The problem isn’t inserting it into the body of the post. The theme I am using adds a block to the page that has like a form in it for additional information. Since it’s for a real estate site, there is price, square footage, etc. and five additional image fields with upload buttons. Before the WP upgrade, those fields worked, now when I click “insert into post” on the image, the URL does not go into the field box in that section.

    Moderator kmessinger

    @kmessinger

    Forum Moderator

    If it is a commercial theme the developer is responsible for keeping the theme compatible with wordpress and for support.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘uploading images’ is closed to new replies.