WordPress.org

Forums

uploading images (8 posts)

  1. sheilaw
    Member
    Posted 6 years ago #

    I cannot upload images or pictures. When I try, this is the error message that I get: "unable to create directory/home/nich/public_html/wp-content/uploads/2009/05." What do I need to do. I am using the DIY Thesis theme template.

  2. Josh Leuze
    Member
    Posted 6 years ago #

    You need to check and see if you have an uploaded folder in that location, if you don't, create one, and then change the permissions so that that directory is writable.

  3. crafty0000
    Member
    Posted 6 years ago #

    Hi, I am having the same problem as this too. In Layman terms, how do I go about creating an upload folder and where do I do it?

    Thanks!!!

  4. Josh Leuze
    Member
    Posted 6 years ago #

    Make sure you are using all of the default settings, that should give you less trouble.

    To create the folder, you need to access your website via FTP, navigate to the "wp-content" folder, and in there create a new folder called "uploads". Then you should change the permissions of that folder so that WordPress can write to it. Setting the folder to 755 should work, but you may need to use 777.

  5. crafty0000
    Member
    Posted 6 years ago #

    It would appear that I already have a folder called uploads inside the wp-content folder. And the permission is already set at 777 but wordpress still fails to recognise it.
    The root directory inside my wp-content folder has 2 folders inside it called uploads and then has a further sub-heading called uploads but isnt a folder. When I click on this i am able to find the only image that is working on the website. Any ideas what is going on?

  6. crafty0000
    Member
    Posted 6 years ago #

    I should also add that when i go to wp-content/uploads I am unable to see any of the upload folders...............
    Just Parent directory and then name of the image that exists on the website.

    Thanks!

  7. Josh Leuze
    Member
    Posted 6 years ago #

    You shouldn't have two directories with the name "uploads". Make sure you have one folder called "uploads" in your "wp-content" directory and delete the other one.

    Double check that the permissions on the one that is left are "777". Then go into the "Miscellaneous Settings" subpanel of your admin panel, make sure that the value of "Store uploads in this folder" is set to "wp-content/uploads".

    I would also uncheck "Organize my uploads into month- and year-based folders", then WordPress will not have to create new folders, which could be an issue on some server configurations.

  8. margulies
    Member
    Posted 5 years ago #

    Thx. I used this for the old version of thesis for this site http://www.cashmakerelite.com and it worked.

    However, when I updated thesis I didn't have to do it again. I don't know if it was because I already did it or if it was the update that fixed the problem. Thx tho! =)

Topic Closed

This topic has been closed to new replies.

About this Topic