WordPress.org

Forums

Uploading images (10 posts)

  1. crisjb
    Member
    Posted 8 years ago #

    I modified the permission settings of my wp-content folder to 777 so that images and other files could be uploaded but when I try to upload I get this message:
    "The uploaded file could not be moved to"
    What could be the problem since my permission settings are fine?
    Any help would be much appreciated.

  2. jmansir
    Member
    Posted 8 years ago #

    I'm having the exact same problem. After I changed my permission settings I got the error of "The File could not be moved to" as well.

    If anyone has an answer to this mystery please let us know.

  3. shimon
    Member
    Posted 8 years ago #

    Not sure if this is the problem, but change permission on the uploads folder that is within wpcontent. should be on 777

    post the results so others with the same problem could find the solution :-)

  4. krs1
    Member
    Posted 8 years ago #

    same problem here. All wp-content & it's contents are set to 777 but keep getting this error: -

    The uploaded file could not be moved to /home/mysite/public_html/wp-content/uploads.
    Warning: Cannot modify header information - headers already sent by (output started at /home/mysite/public_html/wp-admin/admin-functions.php:1879) in /home/mysite/public_html/wp-includes/functions.php on line 1219
  5. jmansir
    Member
    Posted 8 years ago #

    I've already set my permission settings on all folders to 777. But I still get the error of "The uploaded file could not be moved to."

    That's it and I don't even get the "Cannot modify header..." at all.

    I can however link to an image that's already at a URL with no problems. But we want people to be able to upload their own images.

  6. ronchicago
    Member
    Posted 8 years ago #

    are there pix already up there or is this the first. also check ownership = name, not chmod #'s, and verify paths, etc. what are you using modify permissions, etc,? cpanel?

  7. jmansir
    Member
    Posted 8 years ago #

    I was finally able to get mine to work. I had to create a new folder within the wp-content/uploads section using an ftp client (I just use Dreamweaver). Make sure that the permission settings were set to 777. I then manually uploaded through Dreamweaver the first photo. I then deleted the original folder then renamed the new folder the same as the original. After that the upload image feature worked fine.

    Example of what it should look like when done:

    *wp-content folder
    *uploads folder
    *2007 folder
    *04 folder

  8. kevinclapcott
    Member
    Posted 8 years ago #

    I have had the same problem and found that I had to create the new folder(s) using my server control panel (Plesk 8.1.1) - I use WS-FTP and although this says the folder is '777', my control panel told me different!

  9. ronchicago
    Member
    Posted 8 years ago #

    Interesting. I went from Plesk to c-Panel because I couldn't change permissions. Never tried creating a new folder though. But c-Panel is pretty slick, more powerful. I am going to migrate everything eventually. Glad it working!

    I use Dreamweaver to code server-side and in the above process I discovered Capatain FTP for upload/delete management. Mac only though and very easy to use.

    The next chapter is audio and video I hope! Just started researching.

  10. laslo
    Member
    Posted 7 years ago #

    That's right! I was fighting with this for a few hours now. Using Core FTP to create new folders, with chmod 777 and all that. I had to check with Plesk 8.1.1 and I saw that those folders were under the Group "apache" and not "psacln" as usual. So I re-created the folder using Plesk, and voilĂ ! works now.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags