Support » Fixing WordPress » Uploading Image HTTP errors and failure to save image editing

  • Hello,

    Two very frustrating issues I am running into.

    1: For images I’ve already uploaded, when I edit them (crop or rotate), click save (yes, I click save), the photos don’t actually save. The little circle just goes around literally forever until I get so frustrated and X out. This is not an internet speed issue.

    2: Now, when I try to upload new images, I get HTTP errors for all of them. I’ve tried clearing my browser’s cache several times and reopening my browser. I’ve tried using a different browser. I’ve tried giving it a rest and coming back to it the next day. Still not letting me upload any images.

    All of the images are from my iPhone. All of my original images on my blog are from my iPhone as well and I’ve never run into this issue. Extremely frustrating as I am trying to write a timely blog post that has a lot of photos in it.

    I am not familiar with coding so if there is code I need to insert into the function, can you please be explicit as to how and where I do that?

    Thank you so much for your help!

Viewing 15 replies - 1 through 15 (of 16 total)
  • Hello, taylorwolframrd, & welcome to the WordPress support forum. Could you please provide us w/a site url?

    Also, could you please try switching to a default theme, i.e., twentysixteen, for example, & see if the problem persists?

    If changing the default theme doesn’t work, you could try renaming your plugins folder to something like plugins.old or plugins 1 Then try saving an image. If it works, then we know there’s a plugin involved. What you do then is to first rename your plugins folder to its original name, & then begin, 1 by 1, to rename the plugin folders back,trying to save an image each time after renaming. Your first candidate to return to its original name is likely a plugin written by core developers, such as Akismet, for example.

    If that doesn’t work, please try opening your wp-config.php file, either in your hosting provider’s file manager or using an FTP (preferably secure FTP), client and change wp-debug from false to true. This is a security risk, so please switch it back when you’re done, but once you’ve changed the setting, please log into your site and copy-&paste any errors you receive into your next reply.

    Please let us know how that works or if you have questions regarding these instructions.

    Thanks, Jackie!

    My site is http://www.wholegreenwellness.com

    I am a WordPress novice. As far as changing the theme to something basic such as twentysixteen, is this something I do temporarily just to get the images to load and then switch back to my site’s theme? Or does it have to be permanent?

    Can you please provide explicit instructions on how to rename the plugins folder? Do I open “editor” under plugins and manipulate the code in there?

    esmi

    (@esmi)

    Forum Moderator

    As far as changing the theme to something basic such as twentysixteen, is this something I do temporarily just to get the images to load and then switch back to my site’s theme? Or does it have to be permanent?

    That depends upon what happens when you make the switch. There is no magic bullet in these situations, so we need to carry out some basic troubleshooting – a process of elimination deliberately designed to locate the root cause as quickly as possible by first removing the most obvious and common culprits via a series of (often) temporary steps.

    Your theme & plugin settings are saved in your database and should be retained for future use.

    Can you please provide explicit instructions on how to rename the plugins folder?

    See resetting the plugins folder

    Thanks, Esmi!

    I manually deactivated all of my plugins and it is allowing me to upload images (no HTTP error, wahoo!).

    Now, after I finish this post, can I go ahead and reactivate my plugins? Do I need to do them one at a time in order to see which one is causing the issue?

    Thanks all for walking me through this!

    esmi

    (@esmi)

    Forum Moderator

    Do I need to do them one at a time in order to see which one is causing the issue?

    This! Otherwise, you’ll almost certainly have the same problem, back again.

    Unfortunately it is still being finicky. I was able to upload a couple images at once. Then the next round it only successfully uploaded 1 of 3 images. Then I tried to doing them 1 at a time and now they are all getting the HTTP error.

    Any other suggestions?

    esmi

    (@esmi)

    Forum Moderator

    Have you spoken to your hosts about this? This is sometimes caused by an over-aggressive configuration of your server’s mod_security module. Try asking your hosts about it.

    Hi again, taylorwolframrd. Did you first try switching themes? On your dashboard, go to ‘Appearance > Themes’. You’ll see the theme you have activated, followed by those you can activate. Please try activating one of these & then uploading an image.

    Thanks, Ezmi. I’m in the western US, so I’m pretty far behind in terms of timezones.

    i am having this exact same problem. tried all of the ideas listed above and reached out to the host with no solution. any other options?

    Jackie — no, I haven’t tried switching themes (I’m too scared of messing up my site).

    Esmi — I spoke with my hosts yesterday and they increased my upload capacity but that didn’t fix the issue.

    marshalljohns — I would love to try that code. I am confused how it works though … I see how to open the “editor” under plugins but it appears there is a separate code section for each plugin. Can you help me understand how/where to use this code to fix the issue once and for all?

    Thank you very much!

    Now I am getting nothing but HTTP errors even with all of my plugins deactivated 🙁 Am really interested in using the plugin code!

    I had the same problem, switched to 2016 theme and the problem disappeared.

    But what is the problem, I don’t want to use the 2016 theme.

    Thanks.

    Taylor
    i’m not a developer so keep that in mind…
    go to Appearance in your wordpress dashboard and select Editor. On the right you will see all the pages in your template. select Functions.php and add the code.

    add_filter( 'wp_image_editors', 'change_graphic_lib' );
    
    function change_graphic_lib($array) {
     return array( 'WP_Image_Editor_GD', 'WP_Image_Editor_Imagick' );
     }

    then update the file. if it doesnt work you can go in the same way and delete it.

    so far this has fixed my issues.

    hope it helps and sorry for the late reply.

    p.s. I know that the forum watchdogs will want to see an explanation on what this code does and how it works. i have no idea….

    Hi, marshalljohns. You are aware, right, that when you update your theme, that code is going to be history?

    In order to preserve those changes, you’ll likely need to create a child theme. You can find out how to do that here:
    https://codex.wordpress.org/Child_Themes
    If you’d like help from a plugin, you might wish to consider:
    https://wordpress.org/plugins/one-click-child-theme/
    or you can search for child theme when in the ‘Add New Plugin’ portion of your dashboard.

    HTH.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Uploading Image HTTP errors and failure to save image editing’ is closed to new replies.