WordPress.org

Forums

Uploading Files To Media Library (4 posts)

  1. furby
    Member
    Posted 6 years ago #

    Hi all,

    So I installed WordPress 2.7 for the first time and everything seems to be going well but I can't upload files to the media library.

    I don't get any error messages and I tried some of the things on the sticky post at the top but no joy. I'd like to figure out how to fix it, but in the meantime. Which folder can I upload files to so that they appear there via FTP?

    Thanks

  2. Josh Leuze
    Member
    Posted 6 years ago #

    WordPress won't just scan the upload folder for files. You have to upload them through WordPress in order for them to show up in the media library.

    However, there is nothing stopping you from uploading files via FTP and manually adding them to your posts. In fact there may be times where you have to do this with very large files.

    But you should be able to get your uploader to work. Make sure you have an uploads folder with the correct permissions, and that it corresponds to where you've told WordPress the upload folder is in the settings.

    But if you can't get it to work, it's probably easier to just try reinstalling WordPress altogether and see if that does the trick.

  3. thinkstart
    Member
    Posted 6 years ago #

    I just wanted to throw my "aha" into the ring. I have been struggling with a similar problem to furby, and thanks to jleuze pointing me to the issue of where wordpress looks for the upload folder in settings, I have sorted things out!

    Up until now, everyone seems to point to permissions as the most likely culprit for uploads not working, but i long ago changed them only to have the problem persist.

    At jleuze's suggestion, i checked out the Setting for uploads under Miscellaneous. At first I thought all looked well and almost moved on, but then tried to delete the leading "/" that was there. Ta-daa! Now the media uploader works!! I don't know how it got in there (wasn't this a default setting?), but my media imports like a champ, now!

  4. emmfan
    Member
    Posted 6 years ago #

    @thinkstart Thanks for the solution. Fixed the problem for me too!

Topic Closed

This topic has been closed to new replies.

About this Topic