Support » Fixing WordPress » Uploading Error – “This script was not meant to be called directly.”

  • Hi,

    I cannot get my upload to work at all….it says the following when i try to upload a file:

    “This script was not meant to be called directly.”

Viewing 9 replies - 1 through 9 (of 9 total)
  • whooami

    (@whooami)

    Member

    umm.. are you attempting to call wp-admin/inline-uploading.php directly, ie, like :

    http://www.yourdomain.com/wp-admin/wp-admin/inline-uploading.php

    cuz thats the only way I can duplicate that error, and thats not how its meant to be used.

    Im just writing a post….using the Upload button? Insist that how you upload a file ?

    whooami

    (@whooami)

    Member

    yeap, sounds like your trying to do it the right way.

    hmmm……is it only used for image uploading?

    How large is your upload? If it’s greater than 2MB, you need to increase the value of upload_max_filesize in your php.ini. And if it’s greater than 8MB, you also need to increase the value of post_max_size.

    T’anks! I’ll investigate …… stand by ……………..

    ……………………. checking ……………………

    can’t find php.ini. where might that be?

    btw, is this a big time geek app? I find user friendliness here (other than your patient guidance) daunting.

    Actually, I am getting the same error, but instead its when I try to login to the admin cp. I just installed wordpress and I tried to login like I have many times before and it gave me that error. I have no idea what it means and I know it has nothing to do with php.ini

    Got this message today when I wanted to upload (inline) MP4 files exceeding 8 MB (the default setting in php.ini).
    I solved by setting the previously mentioned parameters in php.ini. Many thanks!

    OS: Windows 2003
    Webserver: Apache 2.0.58
    PHP: 4.2.2

    some hosting services don’t let you change the php.ini file directly, DreamHost for example, but they have a workaround for it which works just fine. check out http://wiki.dreamhost.com/index.php/PHP.ini

    And you can also change this on DreamHost when you’re running several domains under one account; creating several .sh file and adding them all line by line to a cron job.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Uploading Error – “This script was not meant to be called directly.”’ is closed to new replies.