Uploading Custom Woo Theme W/FileZilla (8 posts)

  1. spenceri
    Posted 5 years ago #

    I've uploaded many zipped file themes using FileZilla, but for some reason when I log into my admin's theme page it says:

    “The following themes are installed but incomplete. Themes must have a stylesheet and a template.

    Name Description
    angel Stylesheet is missing.
    blackwhite Stylesheet is missing.
    wp-gbcf Stylesheet is missing.

    I can’t figure out what the problem is since I am downloading the file strait to my computer, unzipping it, then uploading it strait into my “themes” folder in my hosting account. Why isn’t it uploading the Style Sheet with it??

    Does anyone know why the Stylesheet might be missing? This is beyond me!

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    Download a fresh copy of the theme?

  3. spenceri
    Posted 5 years ago #

    Yes I did. Deleted all the old copied and downloaded new.

  4. esmi
    Forum Moderator
    Posted 5 years ago #

    I can only assume that the download archive is not complete. Try contacting the theme developers/vendors.

  5. spenceri
    Posted 5 years ago #

    Well that is what I assumed, but I tried about 7 different theme files. Now for some reason I cannot connect FileZilla to my hosting account, even though it was working well earlier. Any idea on that one?

  6. esmi
    Forum Moderator
    Posted 5 years ago #

    Your FTP has nothing to do with WordPress. You need to contact your hosts about that.

  7. spenceri
    Posted 5 years ago #

    Yeah I know that, but something is so weird here. I am uploading amazing themes from a very reputable source, recommended in my cpanel of Host Gator, but they are not uploading to my blog. I even called Host Gator and the technical service rep couldn't even figure it out.

    He said it had to be a WordPress problem. The whole theme files are in my themes folder but nothing is showing up!

    However, it does show up when I uploaded the the WordPress uploaded in the admin area, though incomplete, but NOTHING shows up when I do it through FileZilla, as recommended.

    I don't get it! I've cleared out the entire themes folder, and re-uploaded freshly downloaded themes but the problem still exhist. I even tried it with my other blog.

  8. Jeremy Pry
    Posted 5 years ago #

    It's possible that the theme is within an extra folder. So instead of unzipping to


    It might be:

    .. ..style.CSS
    .. .. functions.php
    .. ..etc.

    That's the most likely reason I can think of for it telling you that you have an incomplete theme.

Topic Closed

This topic has been closed to new replies.

About this Topic