WordPress.org

Forums

Uploading and CHMOD help please! (again) (11 posts)

  1. reevo
    Member
    Posted 10 years ago #

    Hey y'all
    Having probs after changing web hosts with uploading files via wordpress.
    I've used absolute-path an cut & paste the details on to my upload page and tried loads of CHMOD settings, including 777, 766, 755, 666 all with no luck. Just can't see why it's not working any more, driving me nuts. I've even thought about trying another plug-in to upload images but what's the point, I'll still get CHMOD errors wouldn't i?
    Any advice?
    Cheers

  2. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Do you get an error ?
    Does it say it's uploaded but no image is there ?

  3. Would you mind copying/pasting the error that you're seeing? What version of WordPress are you using?

  4. reevo
    Member
    Posted 10 years ago #

    Just came back to update that info actually! I was just thinking I should have included it...
    It doesn't look like you can use the file upload feature at this time because the directory you have specified (/home/ektopian/public_html/ektopia/images) doesn't appear to be writable by WordPress. Check the permissions on the directory and for typos.
    So, to reiterate, the directory structure should be perfect as I used absolute_path.php and I've tried various CHMOD settings with no luck
    Thanks for taking the time to look in
    Reevo

  5. Mark (podz)
    Support Maven
    Posted 10 years ago #

    http://www.ektopia.co.uk/ektopia/images/
    Has that got code in ? I see a wp error....
    So the path is
    /home/ektopian/public_html/ektopia/images
    and the url is
    http://www.ektopia.co.uk/ektopia/images
    and it does not work when chmod to 777 ?
    Odd.. try creating a new directory ('pics' for instance) and setting that as the upload dir ?

  6. reevo
    Member
    Posted 10 years ago #

    I AM AN IDIOT
    I was CHMODding the wrong folder!
    So sorry to confuse and waste your time peop's
    As for the errors, I think there's a rogue index file in there that I'll remove tomorrow morning.
    Sorry again, I've had a few other problems with the hosting and I guess I just didn't look hard enough.

  7. Mark (podz)
    Support Maven
    Posted 10 years ago #

    No you aren't - it's an easy mistake to make when things start going wrong :)
    Glad it's all sorted :)

  8. Anonymous
    Unregistered
    Posted 10 years ago #

    I also get the error:
    It doesn't look like you can use the file upload feature at this time because the directory you have specified (C:Domainsonemanmovie.comwwwrootblogwp-content) doesn't appear to be writable by WordPress. Check the permissions on the directory and for typos.
    My permissions are changed to 777, I am using the absolutepath.php, but it still won't work.
    Any ideas?
    When I type it in the top box: it looks like this C:\Domains\onemanmovie.com\wwwroot\blog\wp-content
    but then WordPress changes it to this (it takes out the slashes)-->
    Destination directory: C:Domainsonemanmovie.comwwwrootblogwp-content
    This is the path it recommends
    Recommended: C:\Domains\onemanmovie.com\wwwroot\blog/wp-content
    URI of this directory: http://www.onemanmovie.com/blog/wp-content
    Recommended: http://www.onemanmovie.com/blog/wp-content
    Thanks in advance for any help.
    Brian

  9. Anonymous
    Unregistered
    Posted 10 years ago #

    I'm going to reply to my own message. I figured out how to get around this seeming file upload bug in WordPress.
    In WordPress Admin, under Options>Miscellaneous--here is where you set the absolute path and absolute url to your image upload folder.
    After you have set your permissions on the image folder to CHMOD 777, there is a little trick I had to do for WordPress to accept my absolute path.
    Normally you would write the path with \ backslashes, not forward slashes /, those are for the url. Everytime I would use the backslash \ for the absolute path, WordPress would take them out, making the path look like this:
    C:Domainsonemanmovie.comwwwrootblogwp-content
    Of course there was no folder with that name, so the upload function could not detect the right folder. Then I noticed on the example WordPress gives you:
    Recommended: C:\Domains\onemanmovie.com\wwwroot\blog/wp-content
    You see all backslashes except the last one...Wierd I thought. Well after copy and pasting it in that way, I noticed that WordPress removed all the backslashes and kept the one forward slash in the path. So I figured it was worth a try--I used all forward slashes for the absolute path AND absolute url--It worked!!!
    This is what my absolute path looks like:
    C:/Domains/onemanmovie.com/wwwroot/blog/wp-content
    This is what my url path looks like:
    http://www.onemanmovie.com/blog/wp-content
    Identical!
    Just in case anyone else out there runs into the same problem, this is what I did.
    Cheers.
    Christ, it's nice when something finally works.
    B

  10. oszie
    Member
    Posted 9 years ago #

    I am having difficulty wih this as well. I need help!
    THis is the recommended:
    Recommended: /home/httpd/vhosts/latinhiphoptour.com/httpdocs/wordpress/wp-content

    that doesn't work, I have tried all kinds of other variations, and I sitll get the same error as the people above... any help?

    also what is the image tag for posts?

  11. dotbuzz
    Member
    Posted 9 years ago #

    If you add 3 backward slashes (\\\) it will read one of them and that will do the trick. For example c:\\\windows\\\ will show up as c:\windows\

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.