Support » Plugin: Forminator - Contact Form, Payment Form & Custom Form Builder » Uploaded images show error in gallery

  • Resolved krepsy3

    (@krepsy3)


    Hello,
    I am really satisfied with this plugin, but there is one problem. I Have a image upload set up in the form (file upload strictified to jpg and png). When someone uploads an image, I place it manually into an Envira Gallery gallery to show the image in post. However, the image only shows on the preview, but when clicked to expand to full view, it shows “The requested content cannot be loaded, please try again later”. I can correctly see the uploaded image in media library and I also checked via FTP that the files are uploaded correctly (e.g. not corrupted) and that’s fine.

    When image is uploaded via wordpress media upload, the envira gallery works as intended. I imagine this has something to do with “registering” the uploaded image to server database. Can you help please?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Okay, I tried to dig down more into the problem, and noticed that it really does input the wrong data into the database. The uploaded files go, as is normal for the regular upload, into wp-content/upload/2020/10 folder (as it is currently October of 2020). However, the permalink in the media library shows that it lies in the wp-content/upload/forminator_temp folder.

    The envira gallery allows to correct the permalink and therefore display the image correctly, so it is a temporary solution. But I’d want forminator to set up the permalink correctly. Could you please help?

    Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi @krepsy3,

    I’ve tested file upload with Envira Gallery Lite but I’m afraid that I can’t replicate this issue, every time I uploaded an image it showed a proper path to /uploads/2020/10/ folder.

    It’s actually strange that the forminator_temp folder is mentioned at all, this folder is just there for temporary keeping the file until the form is submitted, once the submit happens the image is removed from temp folder and uploaded to the default WP image folder.

    Could you provide us with export of your form so we can test it further on our end and see if it’s specific to that form or something is on your site causing this.
    You can get the export from Forminator > Forms panel by clicking on the Gear icon next to your form.
    Upload the export file to any file sharing service like GDrive or Dropbox and share the download link here.

    In the meantime, can you tell me if you’re using Lite version of Envira Gallery or pro version?
    Also, could you try submitting a form while Envira Gallery is disabled and see if the image path is correct in that case?

    Cheers,
    Predrag

    Hi, I placed the export into textfile:
    http://www.dracatajablonec.cz/export.txt

    I honestly do not think Envira (I have the lite version) has anything to do with the upload at all. I’ll however test it, of course. I’ll also test disabling the “Enable media replace” plugin, which I imagine might interfere. I’ll let you know how it went.

    • This reply was modified 1 month, 1 week ago by krepsy3.

    Hello, so I tried disabling couple different plugins (Envira gallery lite, Enable media replace, Better search replace, Yoast duplicate post) but to no better; the default media file permalink still goes to the forminator_temp folder.

    Plugin Support Prathamesh – WPMU DEV Support

    (@wpmudev-support7)

    Hello @krepsy3,

    I was able to replicate the issue on my site too. When I deep checked things, I was able to make why my colleague was not able to replicate the issue initially and the reason is we initially tried with a single file upload option but when we tried to pull up a test using the form you sent where the upload field was set to multiple fields, we could replicate the same.

    We have sent this to the Forminator team to check this and also see if there can be a quick fix for the same. We would update you once we have an update from the team about it. Also, thank you so much for bringing this to our notice.

    Thank you,
    Prathamesh Palve

    krepsy3

    (@krepsy3)

    Thank you for reply @wpmudev-support7, I’m glad you managed to track down the cause of the issue. I will temporarily change my forms to allow only one image per upload. If this is resolved in next update, please make sure to place it on the changelog list, so that I can see that it was fixed and return to allowing multiupload again. Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.