Support » Plugin: Custom Fonts » Uploaded Fonts do not display on ONLY Microsoft Edge

  • I have uploaded a WOFF2, WOFF, TTF and EOT version of a free to use font called ‘SF Intellivised’ using your awesome easy to use plugin. Using Elementor, I was then able to add the font in to my cover homepage and the Font shows up perfectly in Google Chrome, the Samsung Internet app on my android phone and even perfectly on the now redundant Microsoft Internet Explorer, but it does not show up in the most up to date version of Windows 10’s Microsoft Edge. Instead Microsoft Edge reverts back to a random default font.

    I am using the free version of the Elementor plugin over the ‘Ocean WP’ theme. I am a solid novice and do not know if i need to use Elementor over ONLY one of your compatible themes (like Astra for example). However the fact that the font shows up in Chrome and even IE suggests something else but i haven’t a clue what i am doing wrong.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • dollhauss

    (@dollhauss)

    Having the same problem.
    Custom fonts do not work on Edge.

    dollhauss

    (@dollhauss)

    I have just fixed the problem on my site.
    It appears that Minifying HTML is the issue.

    I use WP Rocket – by turning off the Minify HTML setting all the fonts show ok on Edge.
    Hopefully you Brainstorm guys can look into this. 😉

    Plugin Support Team Brainstorm Force

    (@brainstormteam)

    Hello @alexakaaj

    We tried checking the same on our end and didn’t face such an issue.

    Can you update us with which Font you are facing the issue?

    Also, @dollhauss which font you were using and got resolved on disabling the Minify feature?

    Regards,
    Suman

    alexakaaj

    (@alexakaaj)

    Hi everyone,

    ‘@dollhauss’ thank you for explaining what you have discovered. I looked for all the minifying HTML settings i could find on the dashboard and could only find the setting on a preloaded plugin, developed by my host site, which seems to aim to optimise loading speeds through various methods. Interestingly the Minify HTML option on that optimisation plugin was already disabled, along with a bunch of other similar minifying features available. To be sure, i did try disabling the entire plugin, but unfortunately it did not change the outcome.

    Thank you ‘@Team Brainstorm Force’ for your reply. The font is called ‘SF Intellivised’ and can be found at the creators site here

    Happy Christmas.

    Plugin Support Team Brainstorm Force

    (@brainstormteam)

    Hello @alexakaaj

    We tested the same on our end with the same Font and didn’t face such an issue.

    Could you please open a support ticket with the required credentials so that we can debug this issue on your end?

    Regards,
    Suman

    What is it they say with a break through or discovery, eureka? Not sure if this qualifies as a discovery, but i appear to have found a solution to my above problem ‘@Team Brainstorm Force’, so i thought i would share it, in case another novice like me comes along one day:

    i discovered that in the same Host Site optimiser plug-in that i mentioned above, which comes preloaded to the WordPress dashboard (with my host site), i noticed that a ‘Enable HTTPS’ option was DISABLED and so i decided to turn it on, just in case i had a ‘only allow HTTPS secure connnections’ setting somewhere switched on in my Windows 10 (which i could not find). To clarify the function of this ‘Enable HTTPS’ function, according to the plugin it says that it: “Configures your site to work correctly via HTTPS and forces a secure connection to your site.” Anyway, by activating this option and after it configured my site in this way, it appears to have fixed the issue and the correct font now shows on multiple different versions of Microsoft Edge (Build 18362 and Build 18363) on multiple computers where, just before activating this HTTPS option, the font did not show up on 3 different computers that i was using, with these two versions of Microsoft Edge on them.

    So i think that is it sorted.

    Baring in mind my complete noviceness, i found it a odd error, because sometimes when i would load the website up on a new computer for the first time, the font would load correctly. But when i then returned, with no Microsoft Edge update or setting change, the custom font would then not show, which seemed like an unusual error to me. I don’t know enough about HTTPS to know if by not having it enabled, it would cause such a issue?

    Anyway, i hope this is useful and thank you very much for your help.

    Plugin Support Team Brainstorm Force

    (@brainstormteam)

    Hello @alexakaaj

    Glad that the issue is resolved.

    While for the HTTPS issue, we aren’t aware of such an issue. Could you open a ticket and share the steps on how to reproduce the same?

    As it is difficult to debug it without seeing the issue.

    Regards,
    Suman

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.