Support » How-To and Troubleshooting » uploaded file could not be moved

uploaded file could not be moved

  • Hello!
    I just upgrade to WP 2.1.3 and have some problems. I’m missing a lot of my pictures in my ‘uploads’ folder. I can’t copy or ftp to the folder and when I try to upload from wordpress again, i get this message:
    The uploaded file could not be moved to /nfs/vsp/dds.nl/b/bteh/public_html/wp-content/uploads.


Viewing 13 replies - 1 through 13 (of 13 total)
  • Hi,
    An upgrade wouldn’t affect your uploads folder.
    Here is what I see:
    If it’s accessible thru a browser I would imagine ftp wouldn’t be a problem.

    i changed to another ftp-program (filezilla) and changed to 777. but i’m still unable to copy some of the files. with some files it works, but others (like the logo on the frontpage) it doesn’t work, no matter how i try. i really don’t understand…

    I had this problem, changed wp-content and uploads to 777 but it hasn’t helped. Any other ideas of what could be wrong?

    Same problem here:

    The uploaded file could not be moved to /mounted-storage/ddd.com/wp-content/uploads/2007/07.
    Warning: Cannot modify header information – headers already sent by (output started at /mounted-storage/ddd.com/wp-admin/admin-functions.php:1879) in /mounted-storage/ddd.com/wp-includes/functions.php on line 1219

    looks like chmod problem but I’ve assign to all of them 777 and it doesn’t help :(((

    I’m importing an XML file from WordPress, and I get “Uploaded file could not be moved to var/www/ …. wp-content/uploads/2007/08” I changed attributes of the parent directories, but to no avail.

    Update: It worked after I changed the file attributes of every single parent directory to 777, from httpdocs down to 08.


    I tried with Cuteftp and Filezilla and it seems that i change file permissions to 777, but when i click again and i click properties shows again 666, what to do then?


    Try changing the upload address in Options>>Miscellaneous from /wp-content/uploads/ to the FULL directory address i.e. /home/next folder/wp-content/uploads/

    I’m using Coda, so I don’t know how to change my permissions, but I tried to change the upload address suggested by hwjgage, and it didn’t work. When i tried it, it seemed like it spat out the same directory, but with public_html copied twice.




    Best bet would be to discuss the issue with your host then as they would be in a position to assist.

    Not sure why wordpress would default to public_html instead of www.
    However just by changing the permissions to 755 in the /wp-content/upload folder, I was able to fix the problem

    The only way that this worked for me was by going to Options>>Miscellaneous and removing the check mark from option “Organize my uploads into month- and year-based folders”. Everything works fine now, just not got organized photos.

    Hallelujah! x2interactive, you saved me from total insanity! I’ve been working on this on and off for days, and your tip to remove “organize uploads” worked! This was the first time I’d seen this mentioned as a fix, though I’ve seen this problem on the forum over and over, unresolved for many folks. Maybe this would do it for a lot of people.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘uploaded file could not be moved’ is closed to new replies.
Skip to toolbar