WordPress.org

Ready to get started?Download WordPress

Forums

Uploaded file could not be moved to... (17 posts)

  1. monnibo
    Member
    Posted 6 years ago #

    When I try to upload pictures today (it worked yesterday) I get the following message:

    The uploaded file could not be moved to /home/username/public_html/blogtitle/wp-content/uploads/2008/02.

    104

    I checked the permissions on my uploads and wp-content folder, both were at 755 so I tried 777 and it didn't help. Any suggestions??

  2. Jeremy Clark
    Moderator
    Posted 6 years ago #

  3. julxz
    Member
    Posted 6 years ago #

    hi monniblog..

    we encountered the same problem..
    The problem is not in the wordpress code..
    Its in the server, your hosting site. One hosting site that i know that this problem would occur is the Media Temple.

    What you should do is to manually create the directory.

    /home/username/public_html/blogtitle/wp-content/uploads/2008/02.

    first is remove or rename the 2008 directory then set the CHMOD to 777.
    Then create the 01-12 directories then set the CHMOD to 777.

    This problem would actually occur because of the security of the hosting site. WordPress create directories in ur uploads folder but the CHMOD cannot be change even if you will manually change the permission. When you will view the uploads directory on your ftp, u can see the directory created but the thing is its just like a ghost. ITS NOT REALLY THERE!!!...

  4. seanmcauliff
    Member
    Posted 5 years ago #

    General question - I've seen this fix in a number of places and I'm wondering if it's a security issue to have all of these folders set to 777? Thanks.

  5. Anonymous
    Unregistered
    Posted 5 years ago #

    Yes, I also use Media Temple, I was able to fix it just by changing the permissions of the 2008 folder. I've also updated the permissions of the parent folder 'uploads' which I'm hoping with be inherited next year when the '2009' folder is created? Thanks for the post guys, very helpful.

  6. Cruxwire Web
    Member
    Posted 5 years ago #

    seanmcauliff asked:

    "General question - I've seen this fix in a number of places and I'm wondering if it's a security issue to have all of these folders set to 777? Thanks. "

    and I have the same concern. In order to get image uploading to work, I had to manually create an uploads folder and set its permissions to 777. wp-content, its parent folder, is at 755.

    I'm uncomofortable with leaving the uploads folder at 777. I don't know much about chmod or permissions, but it seems like public access means someone could upload a nasty pic with the same name as one of mine, overwrite mine, and thus show the world whatever disgustingness they would like. On my site.

    Anyone who knows more about security that can offer an informed opinion?

    Thanks.

  7. omgitztrey
    Member
    Posted 5 years ago #

    I'm with Media Temple too and just got onto their (dv) server. I really don't want to leave my images folder to 777. Is there anything else that is safe?

  8. Dzikri Aziz
    Member
    Posted 5 years ago #

    I'm not with Media Temple, but with NFS (NearlyFreeSpeech.net). I experienced the exact problem, and what I did was:

    • copied the 2008 dir to something else (eg. old2008)
    • copy old2008 to 2008
    • set the owner and group of the new dir to me:web
    • give the group 'web' permission to write that dir

    oh, i did all of this via SSH ;-)
    PS: sorry for my english

  9. arnonel
    Member
    Posted 5 years ago #

    I am also struggling with this.

    any help would be appreciated.

  10. billyk2373
    Member
    Posted 5 years ago #

    I reckon I've done 20 wordpress installations without any problems, including three on the one server. I't's only with WP 2.6.2 that I've had this problem. 2.6 is OK. I'm reverting to the server based wordpress install - 2.3 and maybe I'll try to upgrade from there, but it's really frustrating having to do all the chmod, .htaccess etc and get nowhere.

    It would be nice if someone of superior knowledge could post the most likely causes and the best fixes for each.
    Cheers
    BillyK

  11. MWVD
    Member
    Posted 5 years ago #

    This was my solution:

    In the WordPress admin under settings > miscellaneous set the default upload folder to wp-content/uploads. Then make sure the uploads folder exists and set the file permissions on the folder to 777. This should allow WordPress to write images to the wp-content/uploads folder. If you still get the error delete the uploads folder and recreate it manually and reset the permissions to 777.

  12. truetone
    Member
    Posted 5 years ago #

    This happened to me after moving my WP install to a new server. The solution that finally worked was to:

    1. rename the uploads folder
    2. create a new uploads folder
    3. change the permissions on the new folder to 777 (755 might work as well, I haven't tried that)
    4. move my folders from the old uploads folder to the new one
    5. Upload a file via WordPress

    I should note that my new file I uploaded for the final step was the first one for the current month. The newly uploaded image was able to create a new folder in 'uploads' (in my case uploads/2008/11) and save the image there. This after months of toying around with permissions.

    Of further note: I am not running PHP in Safe Mode.

  13. pezpengelly
    Member
    Posted 5 years ago #

    MWVD - Thank You!

  14. macwunder
    Member
    Posted 5 years ago #

    @ jeremyclark13

    http://wordpress.org/search/The+uploaded+file+could+not+be+moved?forums=1

    What is this supposed to do for us? 255 posts, most not resolved. If you are going to post a link, how about a link to a post with a solution? Most of us got here
    with a search...

  15. rbolesta
    Member
    Posted 5 years ago #

    I was switching my file permissions for the "wp-content/uploads" folder in my ftp client, but it still didn't work. Eventually I checked the permissions of the folders through my host's control panel and the permissions were still wrong. After I changed them there (to 777), I could upload again.

  16. Khashyar
    Member
    Posted 5 years ago #

    After I moved my WordPress installation to a nwe (and faster) server, I also could not upload image to the uploads folders...

    I changed permissions to 755, and they still didn't work.

    When I changed to uploads permissions to 777, I could upload again.

    I am going to experiment with making as few of the upload folders 777 as possible, so that I can minimize any security issues...

  17. Geth
    Member
    Posted 5 years ago #

    Had somewhat the same problem and after hours of searching and reading, I finally fixed it. I've put up a summary over at my blog, hope it helps:
    http://geth.me/2009/02/wordpress-permissions-trouble/

Topic Closed

This topic has been closed to new replies.

About this Topic