Support » Fixing WordPress » "Upload themes" button not working

  • Resolved Evie333

    (@evie333)


    Hi I just updated to version 4.2.2 recently and I’m trying to search new themes for the company i work for’s website to test out a different look, however when i click Appearance > Themes and then “add new” nothing shows up. The only thing that shows up are the buttons “featured” , “most popular” etc but when i click them nothing happens. When i press the “upload theme” button nothing happens either. How do i fix this?

    My website is:

    Thanks.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Try deactivating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Twenty Fifteen theme to rule-out a theme-specific issue (theme functions can interfere like plugins).

    Thread Starter Evie333

    (@evie333)

    Thanks James. I switched to the Twenty Fourteen theme (the one we had already downloaded) and it worked. Looks like it’s a theme specific issue! We were using Protein.
    Thanks again!

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Ok, it looks like the author is no longer selling or supporting that theme. Probably best to consider switching to a newer theme.

    I am having the same issue but even switching the theme doesnt help any advice?

    Once i go to the theme page it acts weird such as if your hover over an existing them the “Details” button does not appear. Also when i click Add theme it takes me to the page but with NO themes showing. I cant even add my own themes the button just stays there and does nothing

    I am having the same problem. I see the Upload Theme button, but it does nothing. Does not take me to the next step where I can browse to get a Theme.

    Switching between installed themes Twenty-thirteen, fourteen and fifteen does not help.

    I tried FTPing Weaver-II folder into the Theme folder – both as folder and as zip (then extracting). But then I get an error when clicking on themes when attempting activate Weaver-II – Error 500 – Internal Server Error.
    I remove Weaver-II and no error but still cannot Upload Theme.

    Historyanimated.com/cagneycompany

    Please help?

    I’m having this same problem on a freshly installed 4.3.1 running Twenty Fifteen theme out of the box.

    Can probably FTP a theme up but worried it’s an indicator of something else not right with the setup.

    Any Suggestions?

    I finally got an answer to this problem from my hosting provider …

    It seems that the installer script has been adding a line into .htaccess, which tells the server to use PHP 5.2 in that directory and all subfolders:
    AddHandler application/x-httpd-php52 .php .php5 .php4 .php3

    You can simply remove it and save over, in the .htaccess file for the site’s directory–or comment it out, by adding a # so it looks like:
    #AddHandler application/x-httpd-php52 .php .php5 .php4 .php3

    lisaburbaugh, thanks for the follow-up on this. My hosting provider did the same thing with their installer script.

    Commenting out the php 5.2 AddHandler line worked perfectly for me.

    Help! I’m BRAND NEW to this.. and my 2016 preinstalled theme is not letting me even SEE any free themes. All the same type of issues above but I don’t know how to deal with the code adjustments… Could someone please walk me through this? Thanks!

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    @jjmlsg, Try the advice given in this thread, or open a new thread; https://wordpress.org/support/forum/how-to-and-troubleshooting#postform

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘"Upload themes" button not working’ is closed to new replies.