Support » Everything else WordPress » Upload Storage Size

  • Resolved manafumi_kosherman

    (@manafumi_kosherman)


    Hi,

    I’m currently using wordpress for my blog. However i realise i’m only given 10MB and now i’m running out of space as i couldn’t upload anymore photos. But i understand that wordpress is giving at least 3GBs, however i was only entitled with 10MB. Can i know what is the reason behind it? The blog was created through child theme, so i’m not sure whether it affect the storage size or not.

    I had checked with my host.sg and they say i could have the upload size up to 50MB.

    Thus i would need some help and advise on how to increase my storage size.

    Pls advise and looking forward for your reply.

    Thanks

    Best Regards,
    Kiki

Viewing 13 replies - 1 through 13 (of 13 total)
  • SB

    (@sghb)

    It is your host who can set the Upload limit for you

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    Ask your host what the PHP Upload max size is set to πŸ™‚

    Upload SPACE is the amount of space you have on your server.

    File Upload Size is the limit of how large a file you can upload via PHP.

    manafumi_kosherman

    (@manafumi_kosherman)

    Hi,

    I had checked with my host sg and they came back to me that my PHP setting is set to 50MB and commented that it is nothing wrong wrong with their servers.. However my my side still reflect 10MB. Is there any ways to resolve this?

    Thanks,
    Kiki

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    Put the following code in side the .htaccess file and save it.

    php_value upload_max_filesize 20M
    php_value post_max_size 20M

    See if that helps.

    manafumi_kosherman

    (@manafumi_kosherman)

    Hi,

    Sorry, I had tried to input into .htaccess file, it is still the same, 10MB…is there any other way?

    Many Thanks.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    Make a PHPinfo page and look at that for “post_max_size”

    Not that I think your host is lying, but sometimes they don’t make all the right changes πŸ™‚ I know I don’t remember to all the time.

    To make a PHP info page, open a plain text file on your PC, add the following lines, and save:
    phpinfo.php

    <?php
    
    // Show all information, defaults to INFO_ALL
    phpinfo();
    
    ?>

    Then upload the file to your server.

    Delete this when you’re done, BTW!

    manafumi_kosherman

    (@manafumi_kosherman)

    Hi, sorry,
    I had tried but i don’t see any post_max_size. And it is still the same..Can you advise me step by step?

    Many Thanks

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    If you don’t see post_max_size then that’s probably your problem.

    However here’s how you do a phpinfo: http://codex.wordpress.org/User:Ipstenu/How_to_create_a_phpinfo()_page

    manafumi_kosherman

    (@manafumi_kosherman)

    Hi,

    I had checked. Under local value is 20M and master is 50M. May i know what does it means? And now to proceed further?

    Many Thanks

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    That means that you can upload files up to 50Megs in size.

    You can safely remove these lines from your .htacces:

    php_value upload_max_filesize 20M
    php_value post_max_size 20M

    Looking back on your initial post:

    i realise i’m only given 10MB and now i’m running out of space as i couldn’t upload anymore photos

    Ask your host how much upload SPACE you have.

    manafumi_kosherman

    (@manafumi_kosherman)

    Hi sorry to bother you again.

    I had checked with my host sg and this is the message i got from them,

    “Your account has 5GB of space allocation, 150MB used right now, so you have 4.75GB of space free.

    If you’re seeing 10MB, instead of 50MB per file, your wordpress has a problem. I have proven with a clean wordpress installation that you will see 50MB limit per-file, and you are nowhere near hitting the limit of your account.”

    Can you advise me what is the nest step i should do?

    Many Thanks

    manafumi_kosherman

    (@manafumi_kosherman)

    Hi,

    Many thanks for your help. I had solved the problem. I just went to the super admin and uncheck the box, “limit the post sie to 10MB”.

    Many Thanks for your help.

    Have a good day.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    Next time, tell us you’re using MultiSite!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Upload Storage Size’ is closed to new replies.