Support » Fixing WordPress » Upload pictures error

  • Hi There,

    When we are attempting to create new posts to post on our wordpress blog, we’re getting the following error:

    Unable to create directory /homepages/12/d182967957/htdocs/___2011/wp-content/uploads/2012/11. Is its parent directory writable by the server?

    The link occurs in our dashboard, so I’m not including the site link, but let me know if that would be helpful.

    Our parent directory should be writeable. Could this be an internal WordPress error? Is there also any method of troubleshooting you can recommend?

    Thank you!

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’m having problems uploading photos even though I’m doing nothing different than I’ve done before. I am getting this message:

    “image.jpg” has failed to upload due to an error
    The uploaded file could not be moved to /var/www/

    Does anyone know what to do?

    Our host is WordPress but through yhgfl.

    @alia_artandcommerce: Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.

    @lmckay: As per the Forum Welcome, please post your own topic. Your problem – despite any similarity in symptoms – is likely to be completely different.

    hello @esmi

    I tried your suggestion to modify permissions via my ftp client – I’m still getting the same error. Just for reference, I tried changing the permissions of both the _temp folder and the wp-content folder, but both options are still not working. Is there another work around for this issue? We still cannot upload images.



    Ask your hosts to check if there’s a folder ownership issue on the wp-content folder.



    Hi WordPress – we’re still having this issue. We did discover that this posting error is only occurring when we try to post new galleries. Is there any additional troubleshooting for this? Our permissions are currently set to 777 – so the wp-content directory should be writeable in theory.

    Please let me know if you have any thoughts.


    Ask your hosts to check if there’s a folder ownership issue on the wp-content folder.



    Hi Esmi,

    There shouldn’t be any folder ownership issues on this folder. However, I’m encountering something else with this folder that I think could be related. When I change the permissions of wp-content to 767 (or anything besides 755) the CSS on our site disappears. Have you encountered anything similar in the past? I am now hesitant to alter the permissions of the wp-content as it seems to be interfering with the styling of our site in general.

    Thanks for the assistance!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Upload pictures error’ is closed to new replies.