Support » Plugin: Instant Images - One Click Unsplash Uploads » “Upload Photo” works partially with SimpleHistory

  • 1. Why you call it “Upload”? I would rather say i download it from unsplash.
    2. When i click “Upload Photo”, the spinner appears and never disappears. But i can see the unsplash image in the media library. i’ve noticed it fully works if i deactivate the famous “simple history” plugin. as long it is enabled js console fires this error:

    responseText: “<br />↵<b>Notice</b>: Undefined property: stdClass::$ID in <b>/Users/nicb/Data/_htdocs/wild/wp-content/plugins/simple-history/loggers/SimplePostLogger.php</b> on line <b>94</b>

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author dcooney

    (@dcooney)

    Hi @nicmare
    2. I just installed Simple History on a dev site and Instant Images is working as expected. Tested in Gutenberg and the Instant Images plugin screen.

    I wonder if another plugin is causing the warning. By chance did you try turning off WP_DEBUG to remove the notice?

    cheers,

    Plugin Author dcooney

    (@dcooney)

    @nicmare and I totally missed this part 🙂

    i’ve noticed it fully works if i deactivate the famous “simple history” plugin.

    I’m guessing Simple History is logging the SimplePostLogger warning in REST API responses… Not sure why they would do that.

    alright. i cross posted this issue in SH support forum. lets see what plugin author answers…

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘“Upload Photo” works partially with SimpleHistory’ is closed to new replies.