Upload path - missing field - WP-Admin > Settings > Media files (10 posts)

  1. attosoftonline
    Posted 1 year ago #

    Hi. I have installed versions 3.6 and 3.6.1, and at the settings in the media files, where is the set maximum size field, is missing upload default and the full path to the file. To make it visible that field, you must go into the database, at the options and add a some folder name..

    To understand, install wordpress, and go to settings, media files.. upload path to.. is missing..

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    missing upload default and the full path to the file

    This was removed in WordPress 3.6 (or possibly 3.5 - I don't recall exactly). It's now been moved to the wp-config.php file.

  3. attosoftonline
    Posted 1 year ago #

    You mean you can set that field in wp-config.php? It wasn't useful that shortcut in admin panel?

    (Sorry to say, but, for me, it seems like a one step back.. regarding WP)...

  4. attosoftonline
    Posted 1 year ago #

  5. attosoftonline
    Posted 1 year ago #

    I looked in the the confif file. There's no such option..

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', '');
    /** MySQL database username */
    define('DB_USER', '');
    /** MySQL database password */
    define('DB_PASSWORD', '');
    /** MySQL hostname */
    define('DB_HOST', 'localhost');
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
     * Authentication Unique Keys and Salts.
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     * @since 2.6.0
    define('AUTH_KEY',         '……..');
    define('SECURE_AUTH_KEY',  ‘…….');
    define('LOGGED_IN_KEY',    '………');
    define('NONCE_KEY',        '………..');
    define('AUTH_SALT',        '………..');
    define('LOGGED_IN_SALT',   '…………');
    define('NONCE_SALT',       '…………');
     * WordPress Database Table prefix.
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
    $table_prefix  = 'wp_';
     * WordPress Localized Language, defaults to English.
     * Change this to localize WordPress. A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de_DE.mo to wp-content/languages and set WPLANG to 'de_DE' to enable German
     * language support.
    define('WPLANG', 'ro_RO');
     * For developers: WordPress debugging mode.
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
    define('WP_DEBUG', false);
    /* That's all, stop editing! Happy blogging. */
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');


  6. esmi
    Forum Moderator
    Posted 1 year ago #

  7. attosoftonline
    Posted 1 year ago #

    I know how to edit wp-config, mister..

    Where is the media files "upload path" ??? That is the question..

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    I'm not a "mister", thank you.

    And the uploads folder default to wp-content/uploads.

  9. cuisine lover
    Posted 1 year ago #

    Hi, i got a image upload error problem. Then I go to setting->media->delete the "Uploading file" link. After I did that...the field in box never comes up again!!

    Anyone can help please?!?!!!

  10. Settyness
    Posted 1 year ago #

    Apparently the only thing that esmi knows about this topic is gender differentiation and probably should've left this one alone. That is not what you call support.

    What she was trying to tell you is that you can override any of these settings by defining its respective constant (rather than editing the database) in wp-config.php.

    Make a section for yourself, with a comment line, for overrides, then paste the following on its own line:

    define('UPLOADS', 'wp-content/uploads');

    Inside the second argument, you should put the relative path to your uploads directory (either way, it defaults to wp-content/uploads). Keep in mind, this will not bring the option under settings back, but you can just use config.php in the future.

Topic Closed

This topic has been closed to new replies.

About this Topic